Double voip registrations

Discussion in '3CX Phone System - General' started by hoosier1077, Mar 28, 2011.

Thread Status:
Not open for further replies.
  1. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Hello again, I figured I would include my logs in case it helps anybody figure this out. I have my 3cx server setup with static port mapping, static public ip. I use inphonex as my voip provider, and they say this is not a problem on their end. I have always only had one voip setup in my 3cx server, and still only shows as one. The problem is for some reason my 3cx server will go out and register twice, inphonex has two registrations on their end. So when someone calls into my pbx, I get two simultaneous call coming from them. They are telling me that one registration has correct sip5060 port but then this second registration has a number way out of that sip port range. Eveythying else works just fine. For right now I have two cisco 504g phone setup on ext 100. First is on same local lan as 3cx server, and the other at home office which is setup and working just fine. The two registrations is just hard to figure out. I use a sonicwall nsa240 enhanced and the "Consistent NAT" is checked, which in my experience must be checked in order for voip setups to work as they should. The sip assistance and other options within the sonicwall are all off. I have attached my log and maybe you guys will see something i dont, but you can clearly see the server go out and register twice at the same time successfully. I asked them if they thought having two phones on same ext100 (which are on two different networks with two different publics) could cause that, but they said no becuase only the 3cx server registers with them. Thanks for any help in advance.
    This was taken after a fresh server restart...


    12:32:15.418 [CM504004]: Registration succeeded for: 10000@Voip 1
    12:32:14.782 [CM504001]: Ext.IVRForward: new contact is registered. Contact(s): [sip:IVRForward@127.0.0.1:40600;rinstance=69ebb32a769b4c27/IVRForward]
    12:32:14.735 [CM504003]: Sent registration request for 10000@Voip 1
    12:32:14.673 [CM504001]: Ext.EndCall: new contact is registered. Contact(s): [sip:EndCall@127.0.0.1:40600;rinstance=51d2754ee6d46a3e/EndCall]
    12:32:14.673 [CM504001]: Ext.999: new contact is registered. Contact(s): [sip:999@127.0.0.1:40600;rinstance=d368163d3ea12a88/999]
    12:32:14.657 IP(s) added:[10.22.95.132]
    12:32:13.990 [CM504001]: Ext.100: new contact is registered. Contact(s): [sip:100@10.22.95.120:5060/100]
    12:32:13.276 [CM504001]: Ext.*1: new contact is registered. Contact(s): [sip:*1@127.0.0.1:40000;rinstance=2b7baef439f3baa5/*1]
    12:32:13.214 [CM504001]: Ext.*0: new contact is registered. Contact(s): [sip:*0@127.0.0.1:40000;rinstance=139234e191e82a80/*0]
    12:32:13.214 [CM504001]: Ext.*777: new contact is registered. Contact(s): [sip:*777@127.0.0.1:40000;rinstance=5a7fa7ebce7a957d/*777]
    12:32:08.899 [EC100007]: External application is connected: application:ippbxsrv:0/QueueManager local:127.0.0.1:5482 remote:127.0.0.1:1055
    12:32:08.216 [CM504008]: Fax Service: registered as sip:888@10.22.95.132:5060 with contact sip:888@10.22.95.132:5100;user=phone
    12:32:07.610 [CM504004]: Registration succeeded for: 10000@Voip 1
    12:32:07.067 [EC200002]: Media server is connected: application:ippbxsrv:0/MediaServer local:127.0.0.1:5482 remote:127.0.0.1:1052
    12:32:06.834 [CM504003]: Sent registration request for 10000@Voip 1
    12:32:06.539 [EC200005]: Parking Orbit server is connected: application:ippbxsrv:0/3CXParkOrbit local:127.0.0.1:5482 remote:127.0.0.1:1050
    12:32:06.167 [EC200004]: IVR server is connected: application:ippbxsrv:0/IVRServer local:127.0.0.1:5482 remote:127.0.0.1:1048
    12:32:05.857 [EC200006]: Conference server is connected: application:ippbxsrv:0/3CXConferenceRoom local:127.0.0.1:5482 remote:127.0.0.1:1044
    12:32:05.468 [CM506005]: Public IP=staticpublic is used for WAN communications through local interface with IP=10.22.95.132
    12:32:04.625 Failed to obtain short path name for [C:\Documents and Settings\All Users\Application Data\3CX\Bin\Cert]
    12:32:04.625 [CM501006]: Default Local IP address: [10.22.95.132]
    12:32:04.625 [CM501007]: *** Started Calls Controller thread ***
    12:32:04.609 [CM501002]: Version: 9.0.15776.0
    12:32:04.609 [CM501001]: Start 3CX PhoneSystem Call Manager
    12:32:04.375 [EC200001]: Configuration server is connected: application:ippbxsrv:5485/DBProvider local:127.0.0.1:1043 remote:127.0.0.1:5485
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    A couple of questions. Do you have 3CX set up to use STUN, or is it diabled? I don't see a STUN request in the logs.

    No, your extensions, no matter where, are handled by 3CX.

    When you first put in the trunk, did you encounter any problems? Have you tried removing it completely and re-entering? Did they tell you what the other port number was? Is there any more (useful) information shown, if the logs are set to verbose mode?
     
  3. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    STUN is shutoff, and I have entered my public ip on the which ip to use in "Contact" Field for registration. They told me that the second registration is using port 54072. A couple quick things... I did just notice that the time between registration attempts in the voip setup was 600 seconds, I dont think that was the default, and I have now changed to 3600 as I believe I remembered seeing that being the default in some other forums i read. Also, I am using static port mapping and have it setup with the same static public ip as my firewall. Should I use another static public ip that I have from my isp and just use it soley for my 3cx server. I wasnt sure if that had been known to maybe cause problems. im just trying to thing of everything that may help resolve. Thanks for getting back to me. I have setup to use detailed log and resend if you think it would help.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    The registration time is usually "suggested" by the VoIP provider. You can usually set this lower and they will still be happy, but, if you set it too high then, after a set time, they may assume that you are no longer there. If 3600 works for you, then it is probably safe to leave it, they may want it set lower.

    You have two IP's with the same provider? If you have two available, one to each of two routers, and one is not used at the moment, then I would use that solely for 3CX to aid in any future troubleshooting. Modem-> switch-> two routers It all depend on whether or not you want your phones on the same LAN as your other computers.

    I wonder if your router is doing some re-mapping of ports?
     
  5. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Well I have a pack of 5 static ip's to use with our T1 service. The first is being used by firewall/router in order to bring up internet service. The others are for servers, etc... that we may need to assign public ips for in future. Kind of like a situation like this, but I figured I could just use the same public ip as my firewall/router because the ports required by 3cx to work werent being used yet. Even though I have a static public, do you recommend I try using stun server in 3cx setup. Maybe that will take my nat out of the equation and fix my issue, in case my router is causing this problem?
     
  6. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    Also, in case this helps. My registration on inphonex end will get down to just the one single registration after the second one expires with no activity on the pbx, but as soon as I place a call into the pbx from my cell phone, I see the second registration show up on their end.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    You could try enabling it during a low traffic period, then re-start 3CX and see if there is a difference. Did your provider recommend disabling it?

    So, 3CX is behind your existing router at the moment, right?
     
  8. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    No they didnt recommend it, but I thought by reading the 3cx setup guides I was told that if I have a static pulic ip address from my ISP, that I should turn stun off in the voip provider setup. Really in all areas of the 3cx setup, except of course any external extensions like the one at my home office. I believe that any phone setup as an external extension must have stun enabled. Which mine does, and it functions as it should. Should I have kept stun resolution check and setup this whole time on the server? Maybe I jumped the gun by disabling it and using my static public ip in the setup? However I thought all stun does is go out and find your public ip, but if mine doesnt ever change and I specify it in the setup I figured stun should be disabled.
     
  9. hoosier1077

    Joined:
    Mar 5, 2011
    Messages:
    52
    Likes Received:
    0
    yes, my 3cx server is behind my router
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,859
    Likes Received:
    301
    STUN actually runs a series of test to determine the sort of NAT you are dealing with. This has a nice flowchart that explains it well. http://en.wikipedia.org/wiki/Session_Traversal_Utilities_for_NAT Since your 3CX is behind a router and I'm assuming has a private IP on the LAN behind that router, I would try enabling STUN and see what happens (low traffic).
     
Thread Status:
Not open for further replies.