Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Draytek 2860 and WebRTC (no audio)

Discussion in '3CX Phone System - General' started by robxbl69, Apr 3, 2015.

Thread Status:
Not open for further replies.
  1. robxbl69

    Joined:
    Jun 8, 2013
    Messages:
    25
    Likes Received:
    4
    Hi all,

    Anyone using a Draytek router and successfully has WebRTC working?

    I upgraded to 12.5 last weekend and other than a few issues with CTI mode on 3CX Windows phone all is good so far.

    WebRTC works fine over the LAN and I have a couple of directly connected remote extensions and one via the tunnel. All remote extensions both hardware and soft phones are working 100% with no audio issues.

    I've opened up the extra RTP ports on the router/firewall for WebRTC, but when I connect to the webpage from outside the LAN and click the call button, it rings, but I cannot get any audio either way once the call is established.

    Have disabled firewall in the router and have also disabled the Windows firewall, but all without success :(

    Any ideas as I'm losing the will...

    Thanks,


    Robert
     
  2. robxbl69

    Joined:
    Jun 8, 2013
    Messages:
    25
    Likes Received:
    4
    Since posting this, I've tried connecting from the outside world from a couple of other locations (and therefore different routers etc) and get the same results, so definitely looks like it's an issue either with 3CX or the Draytek router.

    Can anyone who has WebRTC working post what router they are using please.
     
  3. robxbl69

    Joined:
    Jun 8, 2013
    Messages:
    25
    Likes Received:
    4
    Re: Draytek 2860 and WebRTC (no audio) now working :)

    I now have this working :D

    I have changed a few settings, but I'm 99% sure than it was due to STUN being enabled in 3CX. I'm (again) 99% sure it was disabled before the upgrade to 12.5, but maybe I'm wrong.

    The only other changes I made was to enable video (but have since disabled again and is still working) and to activate 3CX Web Meeting.
     
  4. danielevz

    Joined:
    Jul 6, 2015
    Messages:
    5
    Likes Received:
    0
    I disable stun and it finally work !!

    for audio to work you must disable STUN in settings, network.
     
Thread Status:
Not open for further replies.