Draytel SIP

Discussion in '3CX Phone System - General' started by Nick_M, Aug 11, 2014.

Thread Status:
Not open for further replies.
  1. Nick_M

    Joined:
    Aug 11, 2014
    Messages:
    7
    Likes Received:
    0
    Hi All,

    I have searched and read everything I can find re 3CX and Draytel, and it appears that some of you have successfully managed to set this up. I also see some had problems and then got connected but they don't say what they did to cure the problem!

    So here is the problem:

    I am trying to migrate our existing Draytel SIP Trunk from the Draytek IPPBX that we currently have, to a new 3CX installation (V12).

    I have set the VOIP Provider as follows (copied from my working Draytek IPPBX Setup):

    SIP Server hostname or IP: draytel.org
    SIP Server Port: 5070
    Outbound proxy hostname or IP: nat.draytel.org
    Outbound proxy port: 5065

    I then enter my draytel number into the External number, Authentication ID, Authentication password, and 3-Way authentication fields.

    I set the inbound rule to dial my one test extension

    I set the outbound rule as:
    Calls starting with prefix =9
    route: draytel trunk, strip digits=1

    However...I cannot get the 3CX system to register with the Draytel service.

    I get the following message:

    Registration failed for: Lc:10000(@Draytel[<sip:(mysipid)@draytel.org:5070>]); Cause: Cause: 401 Unauthorized/REGISTER from 217.14.138.154:5065

    I have done the firewall check and all passes

    I have double checked my user id/password. I have tried substituting 5060 as server and proxy ports. I have tried removing the proxy details. Still wont register.

    I am now at a loss!!

    Can someone who has successfully implemented a Draytel registration advise as to the settings that worked for them? Currently we have 11 DID numbers registered with them so I don't want to have to change providers if I can help it!!

    TIA

    Nick
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,750
    Likes Received:
    285
    Are you certain that it is supposed to be port 5070, or is that a typo?
     
  3. Nick_M

    Joined:
    Aug 11, 2014
    Messages:
    7
    Likes Received:
    0
    It was 5070 in my draytek ippbx and works fine.

    I did however try it set to 5060 but it made no difference.
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    According to their documentation, the SIP port should be 5060. I would set it this way to be safe, but all else appears to be fine. You do appear to be getting to Draytel despite using thee 5070 port.

    However, the issue is that for whatever reason the credentials are not to the provider's liking. You indicated using 3-way authentication and I find no reference to its use. Try without. You also may want to go back and check the credentials and insure that if you did a copy and paste that an extras space of other character did not accidentally sneak in on you. On the VoIP Provider tabs within 3CX you may want to also check that registrations are required for both in- & outbound settings.

    If after having checked the settings the issue still persists, then contact Draytel as they should be able to look at the registration attempts and steer you to a resolution.
     
  5. Nick_M

    Joined:
    Aug 11, 2014
    Messages:
    7
    Likes Received:
    0
    Thanks for the above.

    I have tried setting both ports to 5060, selected inbound and outbound registrations, and checked checked my credentials are exactly correct. I did notice the stun port was not resolving and that 3CX was using 10.151.1.43:5060 (internal IPPBX address) instead. I set the option to use my static external address instead (assume that was correct thing to do?). Since I have a static address I have turned off STUN in network settings (again assume that's correct?).

    I have a slightly different set of errors now, but still no registration.

    Note:
    Proxy was changed to natproxy.draytel.org at Draytels suggestion.

    DNS does resolve addresses on the IPPBX machine in a CMD window.

    I have contacted Draytel and sent them the attached screenshots so will see what they come back with, however if anyone spots anything wrong in the following images please let me know:
     

    Attached Files:

  6. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Interesting.

    Yes, STUN should be off as Draytel does not support, and yes, the Public IP is also the good choice.

    Did they have you change the SIP Server to an IP from Draytel.org? The reason I ask is that the response code is indicating the server is busy and/or unable to service the request. I do not know if Draytel uses DNS Srv, but you might want to go back to using the hostname. I am surprised that Draytel has not actively monitored the registration attempt so that they could better advise. I would call them again.
     
  7. Nick_M

    Joined:
    Aug 11, 2014
    Messages:
    7
    Likes Received:
    0
    Quick update for anyone who may experience the same issues:
    All up and running now.

    2x problems needed to be resolved:

    1) I had used an old password for the Draytel registration (duh). This was picked up by a very nice lady from Draytel support. Other than that setup as above was all correct.

    2) I then encountered some problems answering inbound calls at all extensions, both internal and external. It appeared that the system was unaware that the call had been answered. Outbound calls to external destinations worked fine. Wireshark snooping showed ne that that the system was trying to process some call info via the VM internal virtual network address of 10.0.0.1 rather than the real network interface. I am unsure as to why this was happening as I checked all interface setting options in the 3CX setup and all indicated to use the real interface rather than the VM one. In an effort to simplify things I reinstalled on a dedicated machine and now all is working fine.

    Anyway many thanks to all those that tried to help.

    Nick
     
  8. orange2

    Joined:
    May 16, 2014
    Messages:
    5
    Likes Received:
    0
    Hi Nick
    Can you post your final config once you got it working please? I am trying the same and would appreciate not having to duck and weave!
    Many thanks
     
  9. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Draytel is part of VoIptalk.org which a supported template already exists for this so the only thing that needs changing is the SIP URL to match the draytel sip url.

    should not be a problem getting this working.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. orange2

    Joined:
    May 16, 2014
    Messages:
    5
    Likes Received:
    0
    Brilliant, thanks; I just changed the reg and proxy addresses to draytel.org both on 5060 and it works, in and out! Yay!
     
Thread Status:
Not open for further replies.