drop calls

Discussion in '3CX Phone System - General' started by css, Aug 16, 2007.

  1. css

    css

    Joined:
    Aug 15, 2007
    Messages:
    21
    Likes Received:
    0
    I am experiencing a lot of dropped calls. It happens everytime we leave someone on hold for more than 30 seconds. It does happenn other times bjt the place them on hold and losing them around 30 secs later happens everytime.
    Thanks for any help.
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    3CX Version?
    Phone (Brand and Model)?

    Please enable the log level to "Verbose (only used for debugging purposes)". Restart all 3cx services or restart 3cx box. Then post the log here.
     
  3. css

    css

    Joined:
    Aug 15, 2007
    Messages:
    21
    Likes Received:
    0
    My phones are Linksys SPA921 and I am using SPA-3000. My version is 3.

    I know this is probably a stupid question but I don't know where to copy the log file from.
     
  4. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Login your 3CX box console via this URL http://3cx_Box_IP:5481

    Under Phone System > Server Status ( This tab for display the console log)

    Under Phone System > General > General settings > Logging level ( This tab to define the log level )
     
  5. css

    css

    Joined:
    Aug 15, 2007
    Messages:
    21
    Likes Received:
    0
    Here is the log after restarting the system.
    Thanks for all your help.

    12:13:22.468 CallLegImpl::eek:nConnected [CM103001] Call(1): Created audio channel for Ln:2025@2025 (192.168.1.201:16436) with Media Server (192.168.1.4:7000)
    12:12:39.421 IVRConnected [CM111000] IVR Server is connected
    12:12:39.421 ListenConnect [CM114000] SL: connected phonesystem:5483/IVRServer at [phonesystem]/IVRServer
    12:12:37.390 CallConf::eek:nProvisional [CM103003] Call(1): Ext.116 is ringing
    12:12:36.953 CallConf::eek:nIncoming [CM103002] Call(1): Incoming call from 2025 (Ln:2025@2025) to sip:2025@192.168.1.4
    12:12:36.312 StunClient::process [CM115002] STUN resolved external IP=64.212.47.248:5060 by server 64.69.76.23
    12:12:36.234 StunClient::process [CM115002] STUN resolved external IP=64.212.47.248:5060 by server 80.239.235.209
    12:12:36.109 StunClient::process [CM115001] Send initial STUN request to 80.239.235.209
    12:12:36.000 CallMgr::Stack::thread [CM106001] ** Enter Stack Loop **
    12:12:35.828 ListenConnect [CM114000] SL: connected phonesystem:0/VoiceBoxManagerService at [phonesystem]/VoiceBoxManagerService
    12:12:35.406 CallMgr::DumThread::thread [CM100004] ** Enter DUM Thread **
    12:12:35.296 MediaServerConnected [CM112000] Media Server is connected
    12:12:35.296 ListenConnect [CM114000] SL: connected phonesystem:0/MediaServer at [phonesystem]/MediaServer
    12:12:35.031 DBA [CM109000] ** Database connection Ok **
    12:12:35.015 CallMgr::Stack::Initialize [CM106000] ** Adding transports **
    12:12:34.984 CallMgr::Initialize [CM100003] ** Initializing SIP stack **
    12:12:34.984 CallMgr::Initialize [CM100002] Default Local IP address: 192.168.1.4:5060
    12:12:34.437 CallMgr::Initialize [CM100001] Version: 3.1.2434.0
    12:12:34.437 CallMgr::Initialize [CM100000] Start 3CX PhoneSystem Call Manager
    12:12:30.734 LoadLicenceInfo [CM100007] Licence was loaded successful
     
  6. cashcom

    Joined:
    May 9, 2007
    Messages:
    3
    Likes Received:
    0
    Drop calls on hold - linksys equipment

    i just fixed a similar issue on my linksys SPA400. it had a setting called "Tear down FXO port when silence detected" with a default setting of 30 seconds or so (i cant really remember) i set it to 600 seconds (10 minutes) and it drops the calls after 10 minutes (go figure).

    hope you can find the same setting on your unit and make the same adjustment.

    cashcom
     
  7. cashcom

    Joined:
    May 9, 2007
    Messages:
    3
    Likes Received:
    0
    found it!!!

    Furher diging on your SPA-3000 gives me the following:

    PSTN Long silence duration is set to 30 seconds by default

    also,

    VoIP Long silence detection is set to 30 seconds by default.

    whichever one you are using change it there.

    cashcom
     

Share This Page