Dropping Inbound Calls

Discussion in '3CX Phone System - General' started by jklaver, Mar 23, 2007.

  1. jklaver

    Joined:
    Mar 22, 2007
    Messages:
    5
    Likes Received:
    0
    I have 2 VoIP providers setup in 3CX, Vonage and Broad Voice. Vonage is working great on out going and incoming calls. Broad Voice is working great on out going calls, but the incoming calls get dropped after 9 seconds. All ports are being forwarded by my router and all fire walls are turned off including windows. It gets dropped regardless of wether it is pickuped or it is going through the automated service. I have tried calling from different phones with the same result. Here is the server log.

    10:39:56.796 StratInOut::eek:nHangUp: Call from Ln:10001@Broad Voice to 101 has been terminated
    10:39:48.406 CallLegImpl::eek:nConnCfmd: ConnCfmd: 10001@L:1@C:17
    10:39:48.312 CallLegImpl::eek:nConnected: Connected: 10001@L:1@C:17
    10:39:48.296 CallConf::eek:nIncoming: Incoming call from Ln:10001@Broad Voice to sip:7043140031@192.168.1.25

    Here are the configuration settings as suggested by others on the forum and Broad Voice.

    Outbound Proxy Hostname or IP sip.broadvoice.com
    Outbound Proxy Port (default is 5060) 5060
    Time between registration attemps (in seconds) 3600
    Stun server Hostname or IP stun.3cx.com
    Stun server Port (default is 3478) 3478
    Registrar/Proxy Hostname or IP proxy.nyc.broadvoice.com
    Registrar/Proxy Port 5060

    I am still using softs since we are just testing this system out. So, far though I really like it. Any help would be great.
     
  2. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    It seems you're using quite old build, isn't it?
     
  3. jklaver

    Joined:
    Mar 22, 2007
    Messages:
    5
    Likes Received:
    0
    I am no using the latest version of 3CX phone system. If the call is answered by the Attendant or the voicemail it will still hang up in about 9 seconds. If a person answers the hone will not hang up. Here is the log file for the auto attendant hang up.

    10:21:49.703 StratInOut::eek:nHangUp Call from Ln:10000@BroadVoice to 100 has been terminated
    10:21:41.203 CallLegImpl::eek:nConnected Established media channel for Ln:10000@BroadVoice: remote=147.135.20.250:11924; local=166.82.182.182:9002
    10:21:41.171 CallConf::eek:nIncoming Incoming call from Ln:10000@BroadVoice to sip:7043140031@192.168.1.25

    Here is the log file for the answering machine hang up.

    10:31:58.203 StratInOut::eek:nHangUp Call from Ln:10000@BroadVoice to 999 has been terminated
    10:31:49.671 CallLegImpl::eek:nConnected Established media channel for Ln:10000@BroadVoice: remote=147.135.20.248:11128; local=166.82.182.182:9002
    10:31:34.421 CallConf::eek:nIncoming Incoming call from Ln:10000@BroadVoice to sip:7043140031@192.168.1.25
     
  4. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Versions prior to RC2 had this issue, but now it's fixed. so I recommend you to download and install latest Release of free version.
     
  5. jklaver

    Joined:
    Mar 22, 2007
    Messages:
    5
    Likes Received:
    0
    I am sorry the "no" in my last post was supposed to be "Now". I am using 3CX Phone System v3.0.1699.0.
     
  6. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Please, make sure that logging level in general settings is set to Verbose, make restart of services and make that two calls, than please send logs to the support. We will try to understand what's wrong.
    And, please, make sure that all 3CX services are up and running. That could be the reason.
     
  7. jklaver

    Joined:
    Mar 22, 2007
    Messages:
    5
    Likes Received:
    0
    I checked the logging and restarted the services. I then place three calls from my cell phone to the phone system. The first call was to an ext that I answered. That call was not dropped and lasted for 00:01:08. The next call was made to the Digital Receptionist and it hung up after about 9 seconds. The third call was set for voicemail and it hung up on me after about 9 seconds. Here is the log set in the appropriate order:

    2007-03-26 10:01:07 7046804315 200 Answered 00:01:08
    2007-03-26 09:57:45 7046804315 7043140031 No Answer
    2007-03-26 09:53:02 7046804315 7043140031 No Answer

    Notice that it says no answer even when the Digital Receptionist and Voice Mail picked up.
     
  8. jklaver

    Joined:
    Mar 22, 2007
    Messages:
    5
    Likes Received:
    0
    The information that I gave you before was not correct. here is he correct log for a call to the Auto Attendant via BroadVoice.

    31 2007-03-28 17:15:19 10000 100 Answered 00:00:08

    Here is a log for the Vonage line which works correctly.

    32 2007-03-28 17:19:44 10001 100 Answered 00:01:36

    There is one thing that I notice when watching the Line Status page. When call the Vonage line it changes to "Connected" when the auto attendant comes on. The Broad Voice line says "Calling" when the auto attendant comes on.

    Any Ideas
     

Share This Page