DST

Discussion in '3CX Phone System - General' started by iamgreen, Mar 20, 2013.

Thread Status:
Not open for further replies.
  1. iamgreen

    Joined:
    Sep 25, 2007
    Messages:
    52
    Likes Received:
    0
    Hello!

    Can anyone point me in the direction of how to configure my phones for DST? I have a client that is using 3CX v11sp2 and I noticed that the Yealink phones are not switching their time to the recent DST change. Where can I make this setting happen? I tried correcting the DST dates in the 3CX console, then provision the phone again, but with no success.

    Thanks!
     
  2. AlexDBarrett

    Joined:
    Jan 25, 2011
    Messages:
    71
    Likes Received:
    9
    Check your provisioning file for the Yealink phones.
    C:\ProgramData\Data\Http\Interface\provisioning

    y00000000000X.cfg

    Look at Time Settings section in this file.

    This below is what I see for UK

    local_time.time_zone = 0
    local_time.time_zone_name = GMT

    Is the appropriate detail in your file for DST? If yes I would suggest a hard reset of a phone via web interface or press and hold "OK" button until it prompts to reset to factory thenn reprovision your phone in the normal way.

    Alex Barrett
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. iamgreen

    Joined:
    Sep 25, 2007
    Messages:
    52
    Likes Received:
    0
    Thank yo so much for your help. It looks like I got a little lazy when I setup this client. To fix this I had to

    1: Edit the DST settings in the 3CX console
    2: Upgrade the firmware on the Yealink t22p phones
    3: Edit the the temple for the Yealink phones (to fix the 24hr time settings)
    4: Instruct the users to hold down the OK button to factory reset their phones

    When the phones came back up all the time issues were resolved! Thanks again!
     
  4. AlexDBarrett

    Joined:
    Jan 25, 2011
    Messages:
    71
    Likes Received:
    9
    DST, Daylight Saving Time.

    Got a little confused there, thought you were talking a regional setting.

    Good that you sorted it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cpontus

    Joined:
    Feb 17, 2012
    Messages:
    42
    Likes Received:
    0
    Hi,

    I am having this exact issue with Yealink phones. While I'm sure a factory reset will work, the fact remains that my phones did NOT adjust their time properly as they were supposed to. I already have the latest firmware, time set to 12h and the DST dates entered. Any ideas?
     
  6. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    So you have set the time zone inside 3cx management console under settings-phone provisioning? You have the correct DST date's set? Do your phones have DNS and access to the internet in order to access the NTP server?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cpontus

    Joined:
    Feb 17, 2012
    Messages:
    42
    Likes Received:
    0
    Yes, I just re-checked the time zone and dates for DST. Phones have DNS servers as part of DHCP (I checked the phone).

    I logged into the phone's web interface to see what settings it has. On my Phone tab is all the DST stuff. For some reason it lists 'Fixed Type' as By Week. It should be 'By Date' using the dates that I entered from 3CX.

    When I look in the Yealink phone template, I see this for DST:

    #Configure the DST type when the DST feature is enabled; 0-By Date (default), 1-By Week;
    local_time.dst_time_type = %%dstEnableDisable%%

    Something is not right. By default, it should be By Date. I never changed this. I am doing to factory reset the phone and check the settings in the web interface again.
     
  8. cpontus

    Joined:
    Feb 17, 2012
    Messages:
    42
    Likes Received:
    0
    Bleh. I reset the phone and once it is reprovisioned the time sets itself an hour back.
     
  9. cpontus

    Joined:
    Feb 17, 2012
    Messages:
    42
    Likes Received:
    0
    Can I get someone from the Dev team to take a look at this? No matter what I do I can't get the time correct on my phones.

    In the y000000...32 template here is what gets generated:

    #Configure the daylight saving time feature; 0-Disabled, 1-Enabled, 2-Automatic (default);
    local_time.summer_time = 1

    #Configure the DST type when the DST feature is enabled; 0-By Date (default), 1-By Week;
    local_time.dst_time_type = 1

    #Configure the start time of DST. The default value is 1/1/0.
    #If the DST type is configured as By Date, the value format is Month/Day/Hour. For example, the value 5/20/10 means the start time is at 10:00 on May 20.
    #If the DST type is configured as By Week, the value format is Month/Day of Week/Day of Week Last in Month/Hour of Day.
    #For example, the value 1/4/2/5 means the start time is at 5 o'clock on Tuesday of the 4th week in January.
    local_time.start_time = 3/10/2

    #Configure the end time of DST. The default value is 12/31/23. The value format is the same to the start time.
    local_time.end_time = 11/3/2

    #Configure the offset time (in seconds). It ranges from -300 to 300, the default value is 60.
    local_time.offset_time = 60

    #Configure the time format; 0-12 Hour, 1-24 Hour (default);
    local_time.time_format = 0

    #Configure the DST type when the DST feature is enabled; 0-By Date (default), 1-By Week;
    local_time.dst_time_type = 1

    Looks like this is set by the 3CX server because I set to 0 and then reprovisioned and it was chagned back to 1.

    ---


    the DST Type type does not match the start/end time formats. If dst type is set to 1 the start/stop format should have 4 numbers separated by slashes. I set the format to 0 and it gets overwritten on re-provisioning to 1 with the wrong start/stop format.

    Also, how does local_time.summer_time get set to 1? In 3CX I can only check or uncheck the box.
     
  10. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    You can modify those settings in the phone provisioning template then re provision the phone.

    I don't have a whole lot of experience with yealink phones. Anything outside of that provisioning file your going to have to contact yealink support for, which I have not had much luck with.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. cpontus

    Joined:
    Feb 17, 2012
    Messages:
    42
    Likes Received:
    0
    I was able to resolve the issue by doing the following:

    1. Deleting the main template for my Yealink phones
    2. Using the 3CX web interface to download a fresh copy
    4. Editing the main template with my custom settings (12h time, no screensaver, backlight off after 60 seconds)
    5. Reprovisioning my phone

    Finally the time is correct! I guess I'll see if it really worked once fall rolls around :)

    Checking the phone's settings in the web interface and the provisioning files show all the correct options now (i.e. Fixed type is By Date instead of By Week).
     
  12. netswork

    netswork Active Member

    Joined:
    Mar 11, 2011
    Messages:
    577
    Likes Received:
    1
    Nice. You probably already did but make sure your renaming your template and applying that to your phones. Otherwise when 3cx releases a new template your changes will be gone.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.