DTMF being sent twice.

Discussion in '3CX Phone System - General' started by jared.adams, May 20, 2015.

Thread Status:
Not open for further replies.
  1. jared.adams

    Joined:
    Jun 28, 2013
    Messages:
    8
    Likes Received:
    0
    Some users have reported instances having trouble dialing into conference bridges. I was unable to tell why this was happening until I attempted to join a bridge that told me which digits I was pressing. When the bridge told me which digits it thought I dialed I found that somewhere along the line in a 9 digit string that two of the digits were sent twice.

    For instance:

    The conference code was 834-476-509

    After dialing the conference code it told me I entered the wrong number and told me that I actually dialed 833-477-650. Two 3's and two 7's.

    This happened multiple times as I tried to dial into the bridge that day. This has happend both with the 3CX softphone as well as the Snom 710 handsets we have. I'm not sure where to begin troubleshooting this. I cant find anything in the logs and wireshark traces dont show information on what buttons were pressed.

    Thanks.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,779
    Likes Received:
    286
    You don't say if this is when using outbound trunks, and if so what type of trunking.
    I have seen the double digit issue previously when using a PSTN gateway. Sets were configured to use audio DTMF and a SIP method. Gateways will (in most cases depending on settings), regenerate the DTMF tone, from the SIP message, to send out on the line. So that tone, and one generated at the set keypad, may be occurring. You may want to review the DTMF Method being used in both the sets, and the gateway, the current choice may not be the best.
     
  3. jared.adams

    Joined:
    Jun 28, 2013
    Messages:
    8
    Likes Received:
    0
    Hi there, thank you for your reply.

    The handsets themselves are of course sip as well as our voip gateway provider.

    When I listen to the wireshark trace between the phone and the pbx there are no tones. There are blips, but no tones. Additionally the same wireshark trace shows no sip messages when dialing buttons.

    https://www.dropbox.com/s/e12ivpfg714319l/3cx.wav?dl=0
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,779
    Likes Received:
    286
    Tones are being passed in one of two methods, or, perhaps two at the same time, which is causing the issue. Either as an audio DTMF tone, as generated by the keypad, or as one of several SIP message types.

    http://www.3cx.com/blog/voip-howto/dtmf-rfc2833/

    You may want to try changing the DTMF Method, on one of the sets experiencing the problem, to see if it makes a difference.

    Perhaps others, familiar with that particular Snom handset can offer up the DTMF settings that they use. Do you use any other make/model phones that are experiencing the same issue?
     
Thread Status:
Not open for further replies.