DTMF Issues

Discussion in '3CX Phone System - General' started by KDVosloo, Mar 6, 2018.

Thread Status:
Not open for further replies.
  1. KDVosloo

    Joined:
    Mar 6, 2018
    Messages:
    2
    Likes Received:
    0
    ok so here is everything I have done and my results.

    Called in on sip Trunk. IVR does not recognize DTMF tones.
    Called in on sip trunk. Ext 100 (reception phone) does not sound dtmf tones from sip.

    Call ext 900 from an ext 100, DTMF tones are sounded.
    Register Account on microsip
    Called in on sip trunk and DTMF tones are recognized.

    therefore the issue is with 3cx DTMF on sip trunk. I have run every possibility looking for the DTMF settings on the sip trunk and have found nothing.

    Can someone assist.

    Thank you
     
  2. Jeremy Bero

    Joined:
    Dec 29, 2017
    Messages:
    10
    Likes Received:
    0
    3CX should handle any kind of DTMF. I don't think there is a way to limit or set the type of incoming DTMF. You can change outgoing DTMF method though (for softphones / 3CX Client)

    Just a related story - likely a problem on your affected SIP trunk provider that they will have to change on their end:

    We had an issue with Cox Sip Trunks. After gathering packet captures and working with 3CX support, 3CX determined Cox was sending RFC2833 DTMF (replaced by RFC4733) but they were not sending the correct amount of end packets (This type of DTMF uses packets instead of audio). Our IVR would repeat the menu because it didn't understand. Cox admitted an issue on one of their "switch" providers and are waiting on a firmware fix.

    Our work-around was to have Cox change the incoming DTMF method to INBAND (this type of DTMF uses audio tones) instead of RFC2833. This fixed inbound but broke our outbound (we couldn't call into other company's auto-attendants).

    We had to tell our 3CX PBX to use INBAND for outgoing DTMF (you can do this under the Phones / Phone Provisioning tab / 3CX Client).

    We also had to set each Yealink phone to use INBAND DTMF. This setting sticks through reprovisioning while using the default templates thankfully.

    RCF2833 is the default outgoing DTMF type for 3CX Client and Yealink - probably most SIP phones I would guess.

    We are using Yealink T4 series phones.
     
  3. KDVosloo

    Joined:
    Mar 6, 2018
    Messages:
    2
    Likes Received:
    0
    So I contacted my SIP supplier and they said they have other 3cx PBX systems in the field and i need to look at the dtmf settings on the pbx.

    their response was



    I also tested ad his 3CX isnt responding to any selections, there is nothing we can do about this, the pbx is not accepting the RF2833 dtmf that we are passing onto it, they need to play around with the DTMF settings on pbx
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    As indicated, change the DTMF type in your endpoints to INBAND. 3CX merely passes what it see, so of the phones are set to use INBAND, then this is how 3CX will pass to the provider.
     
  5. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,016
    Likes Received:
    420
    Hello @KDVosloo

    Are you using a provider from our supported list? If you have a capture displaying the issue i would like to take a look at it. Send me a p.m. with any details so we can take a look at the issue.
     
  6. simply7

    Joined:
    Jan 4, 2016
    Messages:
    38
    Likes Received:
    18
    Do you have a packet capture of a call where the digits fail? If you don't, start one and apply the filter rtpevent to your live capture and see if you receive any when a digit is pressed within your IVR. You should see that the buttons are pressed. If not, then you are not receiving the DTMF. You may also need to try the capture with a filter for sip INFO messages with sip.Info-Package
     
Thread Status:
Not open for further replies.