Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

during call -- other IVR's cannot detect dialed digits

Discussion in '3CX Phone System - General' started by dbergsma, Jan 5, 2009.

Thread Status:
Not open for further replies.
  1. dbergsma

    Joined:
    Oct 27, 2008
    Messages:
    39
    Likes Received:
    0
    Hi Folks,
    during external call to someone's IVR system, it asks 'press 1 for english' -- and, even if I press really, really hard :) -- the other system does not pick up the dialed digit.

    Counterindicators - Internally, the 3cx voicemail works fine with keypress.

    Configuration: v7, linksys spa942 with dial plan of [x*]. as specified.
    The only outbound plan that I have is 'if it starts with a 9, make it outbound' and strip 1st digit.

    Anyhelp would be greatly appreciated.

    Cheers
    Dean.

    Ps: v7 -- is a big improvement -- kudos to the team.
     
  2. mattscott

    Joined:
    Dec 21, 2008
    Messages:
    12
    Likes Received:
    0
    Dean,

    Are you using a VOIP provider or some kind of gateway? It sounds like maybe the phone's DTMF settings don't match what your VOIP provider is expecting. I have worked with a VOIP service before that requires your DTMF settings to be set to in-band (i.e. the touch tones are sent as part of the audio stream). If you set DTMF to out-of-band it behaves just like you describe. The other end never hears your button pushes.

    I am not familiar with that particular phone so I don't know what options you have. Just thought I'd share the similar experience I have had.

    Good luck!

    Matt
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. FoxhallVoIP

    Joined:
    Sep 10, 2008
    Messages:
    12
    Likes Received:
    1
    I've had to change the DTMF settings on the SPA9xx phones I've installed.
    At the bottom of each 'Ext' page [below the codec settings], you'll see a 'DTMF Tx Method:' setting. This defaults to 'Auto'. Change this setting to 'InBand' and all should start to happen how you expect it to.
     
  4. mhanson

    mhanson New Member

    Joined:
    Nov 6, 2008
    Messages:
    186
    Likes Received:
    1
    I had to do the same thing. I would imagine this will work for your solution.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.