Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved e-mail settings - solved

Discussion in 'Windows' started by Ton van Gaalen, Dec 27, 2016.

Thread Status:
Not open for further replies.
  1. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    Just installed 3CX phone system v15.0.0 on Windows10. Installation went smooth. All appears to be working without a glitch. Except for my e-mail settings. I just cannot get e-mail to work. I am using a standard gmail account without 2-factor authentication. If I test with:

    • smtp.gmail.com => 3CX states "invalid external certificate"
    • smtp.gmail.com:587 => the port number 587 disappears from the settings (!??) and 3CX states "invalid external certificate"
    • smtp/gmail.com:465 => the port number is stored in the settings as expected but 3CX states "Operation cancelled"
    I am stuck; anybody who can help?
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,430
    Likes Received:
    540
    Hello there,

    Please make sure that you are using a supported browser (try google chrome) and try accessing your gmail account from the PBX machine so that gmail can authenticate your machine. You will get a warning email in our gmail so you can authenticate your machine.
    Port is not needed from what i tried.
    What certificate did you use to install the PBX?
     
  3. GrimmSh0t

    Joined:
    Dec 28, 2016
    Messages:
    3
    Likes Received:
    0
    I am getting the same error, during the installations I used whichever certificate was available. Meaning I did not import my own certificate
     
  4. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    I am already using Chrome, so that is not the issue. I used the default certificate provided by the 3CX installer. I believe 3CX uses the "Let's encrypt" service to generate a certificate on demand. Nothing out of the ordinary I think, so still looking for help on this one.
     
  5. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    It gets more interesting. If I run a firewall check from the dashboard, the check routine disables/enables the 3CX services as part of the process. To my surprise I received a "Stopped services" notification e-mail. It appears the SMTP mail setup is correct, but parts of 3CX still cannot send out an e-mail. What I want to achieve is send out a welcome e-mail for a new extension (which currently does not work).

    I am lost, so any help is appreciated.
     
  6. GrimmSh0t

    Joined:
    Dec 28, 2016
    Messages:
    3
    Likes Received:
    0
    Good test, I just ran the same test and received the same results.
    I then tried to send myself a welcome email with no luck - still unsure what's going on.
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,430
    Likes Received:
    540
    Please make sure that your windows are fully up to date with windows updates and try again
     
  8. GrimmSh0t

    Joined:
    Dec 28, 2016
    Messages:
    3
    Likes Received:
    0
    Windows is up to date...
     
  9. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    Windows is up to date.
     
  10. Platonik

    Joined:
    Dec 29, 2016
    Messages:
    9
    Likes Received:
    0
    Same issue but using Google Cloud hosting instead. Tried everything mentioned above..
     
  11. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    Ok, I spent several hours troubleshooting. Learned a lot using openssl on the command prompt. In the mail settings screen I changed my mail server to smtp.gmail.com:25 (so I just added port number :25). Mails are now sent and received as expected. Give it a try and let us know if this works for you as well.
     
  12. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    Ok, now I am really losing it. Mail is not sent anymore and error is back to "invalid remote certidficate". I could really use some help as this is costing me too much time now.
     
  13. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,430
    Likes Received:
    540
    i have sent you a p.m.
     
  14. Ton van Gaalen

    Joined:
    Dec 26, 2016
    Messages:
    8
    Likes Received:
    1
    Ok, root cause determined. I use avast mail shield and this somehow interrupts the 3CX mail server communication. Disabled Avast mail shield and set up the mail server in 3CX with smtp.gmail.com (no port #). Now works as expected. Rather obvious; I overlooked it. Solved with the help of 3CX support - Yiannish_3CX. Thx a million.
     
    agp likes this.
Thread Status:
Not open for further replies.