e164 processing

Discussion in '3CX Phone System - General' started by luiscarvalho, Sep 27, 2009.

Thread Status:
Not open for further replies.
  1. luiscarvalho

    Joined:
    Sep 27, 2009
    Messages:
    13
    Likes Received:
    0
    Hi everyone!

    i am trying to dial directly from outlook using the + signal, but for some reason, 3cx is not processing the the number correctly.

    i am dialing the following number +35121XXXXXXX.

    in the e 164 pocessing page i used the following values.

    country code - portugal
    remove if same contry - not enabled.
    international dial code - 00
    area code - 21
    remove if same area code - not enabled
    national dial code - not enabeld
    add prefix - 9


    in the outbound rule, I used the following
    calls starting with prefix - 9
    strip - 1 digit
    prepend - 00

    the folowing, is a copy of the log:

    14:18:23.440 [CM503008]: Call(54): Call is terminated
    14:18:18.341 [CM503007]: Call(54): Device joined: sip:EndCall@127.0.0.1:40600;rinstance=ed2fe2f4693a1412
    14:18:18.338 [CM503007]: Call(54): Device joined: sip:11@192.168.2.2:12016
    14:18:18.334 [CM503002]: Call(54): Alerting sip:EndCall@127.0.0.1:40600;rinstance=ed2fe2f4693a1412
    14:18:18.188 [CM503025]: Call(54): Calling Unknown:Ext.EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=ed2fe2f4693a1412]
    14:18:18.167 [CM503016]: Call(54): Attempt to reach <sip:351219246548@192.168.2.2> failed. Reason: Not Found
    14:18:18.167 [CM503014]: Call(54): No known route to target: <sip:351219246548@192.168.2.2>
    14:18:18.166 [CM503010]: Making route(s) to <sip:351219246548@192.168.2.2>
    14:18:18.157 [CM505001]: Ext.11: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [CP PAO 2.0.2.196] PBX contact: [sip:11@192.168.2.2:5060]
    14:18:18.152 [CM503001]: Call(54): Incoming call from Ext.11 to <sip:351219246548@192.168.2.2>
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    Someone else was having an issue while trying to use the + in place of the international access code that your provider requires. Try using the 00 or pre-pending the number with the 00 in the outbound rules, if you are already trying that, then something is missing if it's not working. Make sure that the outbound rule is based on the digits as seen from the extension, i.e begin with 35 then X number of digits.

    As a general rule the + works great when you are using a mobile and the access code varies depending on the country you travel to, the you don't have to know what it is. But you need something that knows to substitute 00 for the +, if it doesn't then it isn't going to work.
     
  3. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    There's no '+' in the number you've dialed, so E164 parsing is not applicable
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. luiscarvalho

    Joined:
    Sep 27, 2009
    Messages:
    13
    Likes Received:
    0
    hi Archie!

    thank you replying. this seams odd, because I am using the + signal, when I dial from outlook using bria for outlook. is it being discarded by this plug-in?

    Thanks,

    Luis
     
Thread Status:
Not open for further replies.