Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Eliminate Echo Hints - Patton SN 4114

Discussion in '3CX Phone System - General' started by nml, Jan 5, 2010.

Thread Status:
Not open for further replies.
  1. nml

    nml

    Joined:
    Oct 8, 2009
    Messages:
    21
    Likes Received:
    0
    Hi,

    We have 2x SmartNode 4114's = a total of 8 FXO ports. United States.

    I've tried all kinds of settings to remove/reduce the echo. My current best is running G.168, Non-Linear Adaptive Processing mode 9 (are these dB's?) with -4 dB output gain.

    I notice the smartnodes have no way of specifying impedience in reistance or microfarads. Is this correct?

    Is there anything else I can do??
     
  2. danj

    Joined:
    Oct 26, 2007
    Messages:
    16
    Likes Received:
    0
    Hi,

    This article/document provides good discussion on echo problems.

    https://support.deerfield.com/kayakov3/index.php?_m=downloads&_a=viewdownload&downloaditemid=120
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nml

    nml

    Joined:
    Oct 8, 2009
    Messages:
    21
    Likes Received:
    0
    Thanks for the document. After reading it, I think I've taken as many steps as I can with my skill set.

    Is there any way to force a different set of parameters on the analog ports? I hooked up a different gateway on the same lines (grandstream), turned it to the Complex4 setting, and the echo went away. So while I have the echo canceller enabled, hybrid processing, and im reducing the gain as much as I can, I'm still having some issues.

    These are 4114's with the latest firmware (5.4, November 18 build).

    Also, I've heard echo can more pronounced by a grounding problem in the site wiring. Does anyone know how that would work?
     
  4. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Usually if you have spent that much effort and cannot resolve echo than you most likely have a line issue and its time to call the phone company and have them come test the lines. Usually they will find a voltage, impedance, or shorting problem. Once corrected, the default settings will almost always do the trick. Every time I have had to spend more than 5-10 minutes trying to solve echo problems, it has been a line-related issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    I very recently had echo/scratchy noise on one of two 4114's, turned out to be a faulty gateway. The symptoms were that the echo/scratchy noise was very pronounced on internal extensions, outside parties had good voice quality and didn't hear any of it.

    Patton RMA'd the unit, and all is well. If both gateways were faulty, I would probably still be looking for the issue ;-).

    Les.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. nml

    nml

    Joined:
    Oct 8, 2009
    Messages:
    21
    Likes Received:
    0
    I have the telco coming out to check the lines. I've been through seemingly every debug command, every combination of PSTN profile, and a lot of dejitter buffer settings looking for leads.

    Do the fxo profiles on the 4114 for a given country have anything to do with the lines other than tones?
     
  7. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    I'm struggling with this a bit as well.

    All internal calls are excellent quality - it's only when an outside (PSTN) line is involved that there's any issue. I think I've done what I can internally - Polycom Technical Bulletin 16249, "echo on external calls through a gateway", reduce voice.gain.tx.analog.handset. This has resulted in the known side effect of users sounding "quiet" to external parties, and is partly resolved by increasing the volume in the PSTN profile at the Pattons.

    In most cases, the handset (Polycom, in my case) compensates almost adequetly - Echo cancellation is enabled by default - but it takes a few spoken words for the device to "train" and reduce the echo. It's a bit annoying to users, and as with any new system and gaining confidence in it, this doesn't help. There's always "it didn't happen with the old system". ;-). It's not a Polycom issue per se, as I have some Aastra hardphones that also behave the same way.

    So I'm looking at this situation starting at the Gateway (patton), looking outwards. Besides the PSTN profile settings, I don't have any idea of whether there are other configuration options that could use tweaking or not. But I intend to find out, so if anyone has pointers I'd be grateful.

    Thanks - Les.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    There is no reason to struggle with this. If you are having bad echo problems with a Patton you either have a bad device (very rare) or you have poor quality lines (very common). The easiest thing is to get the telco out and test the lines. As a rule of thumb, if you spend more than 5 minutes trying to dial out echo and you still can't, then its a line issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    Thanks, I've got some tests to run as per Patton support. I'll post back with the results, but I seriously doubt it's faulty pattons.

    The telco test will be a last resort, and even then possibly not productive. Unfortunately, the telco is the competition for PBX, and they can't be trusted.

    - Les.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.