email alert does not work ** FIXED SMTP SERVER

Discussion in '3CX Phone System - General' started by Jonners59, Dec 30, 2010.

Thread Status:
Not open for further replies.
  1. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    I have the 3CX install for about 2 years now (current version v9.0.14507.814 SP.5), working fine, but recently I have moved everything over to Linux, namely Ubuntu. I am currently using 10.10 Desktop version for the server. To make 3CX work I have used Sun VirtualBox and within that I am using MS Windows 7 Home Prem. The system works fine, but for two problems. One for this thread and another in a different thread:

    In the General settings there is a facility for eMail alerts and voice mail notification.

    I have entered the details of the email account, which is a privately owned domain hosted by Google. Google requires SSL and TSL to work, but I do not know if this is the problem, but either way, voice messages are not being emailed. There is no test facility on the 3CX - sadly, maybe a development idea.

    I could use an old hotmail or tiscali email address and my local ISP SMTP, but that does not seem to work either....

    Any ideas, please?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Re: email alert does not work

    Hi, have you listed the mail server address within the 3CX Console

    Settings >> General Settings >> Tab "Mail Server"
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: email alert does not work

    Yes, sorry, that is what I meant by the "In General settings".... bit.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Re: email alert does not work

    install a telnet client on the windows 7 virtual pc

    then within telnet do telnet Hostname 25

    and let me know if you get a resposne

    replace hostname with the IP address of the mail server
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mhanson

    mhanson New Member

    Joined:
    Nov 6, 2008
    Messages:
    186
    Likes Received:
    1
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: email alert does not work

    Yes, I realise that, so I have started trying some old personal email addresses, such as name@tiscali.it (smtp.tiscali.it) and isp's smtp, smtp1.betherenow.co.uk, but none of these are working either.

    I will look at the link you sent and I still have to do the telnet test. Shall get back, but if any other ideas, please advise.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: email alert does not work

    MMm Telnet just came back with 220 *****************************

    What does that mean. PS I used Putty as the client. There does not seem to be a built in client or service and it does not seem top work from cmd as it used to....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: email alert does not work

    RESOLVED:

    Windows 7 does not have SMTP, so an SMTP server is required!!!! :twisted: There are plenty of free ones out there. I used this one:

    http://www.softstack.com/freesmtp.html All I did was download and run install. As soon as it installed it was working, just went in to File and Options to make changes, but there was nothing to change. I tried a call and message and it worked just dandy!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.