Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Enable HTTPS / SSL after installing Phone System 12

Discussion in '3CX Phone System - General' started by Copernicus, Dec 17, 2013.

Thread Status:
Not open for further replies.
  1. Copernicus

    Joined:
    Feb 21, 2012
    Messages:
    2
    Likes Received:
    0
    Hi there,

    We have recently upgraded to 3CX Phone System version 12.0.33517.465. During the installation we skipped the configuration of the SSL certificate to support HTTPS. We are using IIS on Windows Server 2008 R2, and have installed the SSL certificate and configured the correct bindings on the Phone System Web Server web site.
    The management interface is now working correctly with HTTPS. However the generated *.3cxconfig files (send welcome email) still contain the HTTP URL for the “MyPhoneServerPublicAddr” XML node, and the External/Public provisioning URL still displays the HTTP URL.
    I’ve already changed the SSLenabled value from 0 to 1, and restarted the 3CX services, but that doesn’t seem to change anything:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\3CX\PhoneSystem\SSLenabled
    How can I enable SSL and make sure the correct HTTPS URL is used for the 3CXPhone clients without reinstalling the phone system?
    Peter
     
  2. AndreasP_3CX

    AndreasP_3CX New Member
    3CX Support

    Joined:
    Feb 15, 2013
    Messages:
    196
    Likes Received:
    2
    hi Copernicus,

    the correct procedure is to select https when you are installing 3CX Phone System 12(and at that point the system creates it's own certificates) instead of doing it after. Even so though the provisioning link will still be send as HTTP and not HTTPS due to the reason that not all phones support provisioning/configuring via https. With the 3CX Cloud Server coming soon though support with https will be available. I hope that that has answered your questions and if you have any further questions or inquiries please feel free to let us know.

    Best Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.