end call not detected by remote phone

Discussion in '3CX Phone System - General' started by yborf, Feb 1, 2010.

Thread Status:
Not open for further replies.
  1. yborf

    Joined:
    Jan 29, 2010
    Messages:
    4
    Likes Received:
    0
    Hi all,
    I'm new, and the follwing it's my first installation of 3CX:
    3CKX phoneSystem 8 + 3CXPhone 4 (10): both installed on the same machine (192.168.1.101). Another 3CXPhone 4 on different machine behaves in the same way.

    I'm able to receive and to do outbound calls.

    The only one problem is that if I start an outbound call from 3CXPhone 4 and than I drop the call on the 3CXPhone 4, the called number phone continues ringing. After that (while the called number is ringing) PBX sees a free line: I'm able to call the same number: it is busy ! right.

    Coud this problem depend on the configuration of me sip provider?

    this is the log:

    15:37:43.932 [MS105000] C:4.1: No RTP packets were received:remoteAddr=127.0.0.1:40006,extAddr=0.0.0.0:0,localAddr=127.0.0.1:16388
    15:37:43.761 [CM503008]: Call(4): Call is terminated
    15:37:30.262 [CM505003]: Provider:[TG] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [IPKOM VCUBE 3.2r15] PBX contact: [sip:SipAccountNum@publicIp:1411]
    15:37:30.262 [CM503002]: Call(4): Alerting sip:SipAccountNum@SIP_PROXY:5060
    15:37:30.022 [CM503025]: Call(4): Calling VoIPline:NumChiamato@(Ln.10002@TG)@[Dev:sip:SipAccountNum@SIP_PROXY:5060]
    15:37:29.861 [CM503004]: Call(4): Route 1: VoIPline:NumChiamato@(Ln.10002@TG)@[Dev:sip:SipAccountNum@SIP_PROXY:5060]
    15:37:29.851 [CM503010]: Making route(s) to <sip:NumChiamato@192.168.1.101:5060>
    15:37:29.851 [CM505001]: Ext.10: Device info: Device Identified: [Man: 3CX Ltd.;Mod: 3CXVoipPhone;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXVoipPhone 4.0.9878.0] PBX contact: [sip:10@127.0.0.1:5060]
    15:37:29.831 [CM503001]: Call(4): Incoming call from Ext.10 to <sip:NumChiamato@192.168.1.101:5060>


    can you help me?
    could you suggest to me do other attempts to discover the reason?

    Thank you




    PS: 3CXPhone 4 registered directly to he same sip provider works fine!
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    This would seem to indicate that a firewall or router is preventing some ports from getting through. The 3Cx soft phone can be misleading as I have found that it will give ringback tone before that call is actually connected unless you "suppress early sounds" on it. So you may not be hearing the ringback from the VoIP provider.

    This is only if the call is never answered? Does it drop correctly if the called party answers but stays off hook after the 3CX softphone hangs up? It sounds like the "Bye" message to the provider isn't getting through.
     
  3. yborf

    Joined:
    Jan 29, 2010
    Messages:
    4
    Likes Received:
    0
    Thank you leejor,

    In
    extAddr=0.0.0.0:0 worries me. But I can't understand if this can be the reason.

    Which are ports I've to check if they are open or not? 40006? 16388? on which port bye message is sent?


    I'm going to try this and then I'll let you know.

    Thank you
     
  4. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    You have a routing problem in the machine

    Check firewall - Disable it or allow proper ports to be opened both on local machine as well as port forwarding on the router.
    Also open the phone go to Connection / Advanced and help the phone more by selecting the outgoing interface on the 192.168.x.x. network.
    You need to help the phone because you have a phone + pbx on the same machine and this is not normal.

    Check route print to see default route of the machine.

    Try and use the tunnel - this is a good way to identify whether the problem is in the network topology or not. If with tunnel, everything works normally, then you definitely have a routing problem.

    Suppress early sounds is unrelated. If END CALL is leaving the phone in ringing state, there is no media to suppress at this stage. The problem is occurring before. Before audio is being passed. Probably the BYE is being sent somewhere else this is why the remote phone keeps on ringing.

    Also Take out the phone that is on the same PBX machine and install it elsewhere - see if this helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. yborf

    Joined:
    Jan 29, 2010
    Messages:
    4
    Likes Received:
    0
    Hi,
    thank you again all.

    I've installed the soft phone on another machine. now phone and pbx are on different machines.
    I cannot select in Connection / Advanced the ip of my PBX as the outgoing interface because it is not available.


    I've applied forwarding to these ports on my firewall/router:
    5060 to my pbx (tcp & udp)
    40000-40019 (tcp & udp) to my pbx

    The problem is always the same, also with tunnel.


    I run Firewall Checker and this is the log
    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <21:13:10>: Phase 1, checking servers connection, please wait...
    <21:13:10>: Stun Checker service is reachable. Phase 1 check passed.
    <21:13:10>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <21:13:10>: UDP SIP Port is set to 5060. Response received WITH TRANSLATION 1267::5060. Phase 2a check passed with WARNINGS. Some functionality will be LIMITED. For more information, please visit http://www.3cx.com/support/firewall-checker.html

    <21:13:10>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <21:13:11>: TCP SIP Port is set to 5060. Response received WITH TRANSLATION 1267::5060. Phase 2b check passed with WARNINGS. Some functionality will be LIMITED. For more information, please visit http://www.3cx.com/support/firewall-checker.html

    <21:13:11>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <21:13:11>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <21:13:11>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <21:13:12>: UDP RTP Port 40000. Response received correctly with no translation. Phase 4-01 check passed.
    <21:13:12>: UDP RTP Port 40001. Response received correctly with no translation. Phase 4-02 check passed.
    <21:13:12>: UDP RTP Port 40002. Response received correctly with no translation. Phase 4-03 check passed.
    <21:13:12>: UDP RTP Port 40003. Response received correctly with no translation. Phase 4-04 check passed.
    <21:13:12>: UDP RTP Port 40004. Response received correctly with no translation. Phase 4-05 check passed.
    <21:13:12>: UDP RTP Port 40005. Response received correctly with no translation. Phase 4-06 check passed.
    <21:13:12>: UDP RTP Port 40006. Response received correctly with no translation. Phase 4-07 check passed.
    <21:13:12>: UDP RTP Port 40007. Response received correctly with no translation. Phase 4-08 check passed.
    <21:13:12>: UDP RTP Port 40008. Response received correctly with no translation. Phase 4-09 check passed.
    <21:13:12>: UDP RTP Port 40009. Response received correctly with no translation. Phase 4-10 check passed.
    <21:13:12>: UDP RTP Port 40010. Response received correctly with no translation. Phase 4-11 check passed.
    <21:13:12>: UDP RTP Port 40011. Response received correctly with no translation. Phase 4-12 check passed.
    <21:13:12>: UDP RTP Port 40012. Response received correctly with no translation. Phase 4-13 check passed.
    <21:13:12>: UDP RTP Port 40013. Response received correctly with no translation. Phase 4-14 check passed.
    <21:13:12>: UDP RTP Port 40014. Response received correctly with no translation. Phase 4-15 check passed.
    <21:13:12>: UDP RTP Port 40015. Response received correctly with no translation. Phase 4-16 check passed.
    <21:13:12>: UDP RTP Port 40016. Response received correctly with no translation. Phase 4-17 check passed.
    <21:13:12>: UDP RTP Port 40017. Response received correctly with no translation. Phase 4-18 check passed.
    <21:13:12>: UDP RTP Port 40018. Response received correctly with no translation. Phase 4-19 check passed.
    <21:13:12>: UDP RTP Port 40019. Response received correctly with no translation. Phase 4-20 check passed.


    Application exit code is 2


    I don't know.....
     
  6. TwigsUSAN

    Joined:
    Jan 31, 2007
    Messages:
    45
    Likes Received:
    0
    Stupid question, but when you tested with the Tunnel Configuration, did you port forward 5090 to the PBX?
     
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Another thing

    1) Leave tunnel for now because if you did not manage to get a local extension to work yet, the tunnel needs an extra later of configuration. We will tackle this later

    2) what is 40000-40019 ? How did you decide to use these ports? Just because you saw 40000 in the logs? This is incorrect. Remove opening of ports 40000-400XX from the router.

    3) First work LOCAL EXTENSIONS ONLY. If you do not have 2 way proper audio in a local call From phone to pbx on same network, you will get 20 times the problems if you try to phone outside.

    4) In a local environment, for now just disable the local firewall on the PBX machine and make a call to 999 again.

    5) In advanced connections of the voip phone you DO NOT see the ip address of the 3CX PBX of course now anymore because now the phone is not installed on the same machine as the pbx. However you see the outgoing interface of the machine where the Voip phone is installed THAT IS IN THE SAME NETWORK AS THAT OF THE PBX. That is the interface you have to select.

    6)
    If he disabled the firewall on the machine where the pbx is installed, then he does not need to make port forwarding. First task he has to achieve is get 2 way audio locally.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. yborf

    Joined:
    Jan 29, 2010
    Messages:
    4
    Likes Received:
    0
    Ok

    I had changed ports from 9000-90xx (normal settings)to 40000-40019. now i've restored normal settings, but nothing changes.

    local extensions work fine

    local firewall disabled, just done. call to 99 works

    Phone installed on different machine as the pbx, but with both the machines on the same network. I cannot see address of the 3CX pbx.


    6)
    If he disabled the firewall on the machine where the pbx is installed, then he does not need to make port forwarding. First task he has to achieve is get 2 way audio locally.[/quote]

    yes
     
  9. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Ok

    So now you have 2 way audio on local extensions right? Something that you did not have before as far as I can remember.

    So what is the next problem? You are calling out from an extension to a number using a voip provider and you get 1 way audio?


    Also something else is clearer to me now.

    Do not use 40000 range of ports. Those are in conflict with ports used for Conference, parking orbit and IVR. If you want to change the external ports use something else example 50000-50049. Keep ports even so starting port should be even and ending port should be Odd number. This way you will have consistency.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.