Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Error Create Database 3cx Debian

Discussion in '3CX Phone System - General' started by Novensca Adi Pradewa, Aug 8, 2017.

Thread Status:
Not open for further replies.
  1. Novensca Adi Pradewa

    Joined:
    Aug 8, 2017
    Messages:
    5
    Likes Received:
    0
    Hello, can help for this error massage ???

    System.NullReferenceException: Object reference not set to an instance of an object. at PostInstall.SetupExecutor.WriteIniFiles(Boolean writePsIni, Boolean writeMediaIni, PhoneSystem root) at PostInstall.SetupExecutor.CreateDatabase(Action`1 stateChanged) at PostInstall.SetupExecutor.ExecuteSetup(SetupSettings setupSettings, Action`1 stateChanged, Action`1 errorNotifier) at PbxWebConfigTool.PbxSetupService.CreatePbxInternal(SetupSettings settings)

    Thax
     
  2. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,222
    Likes Received:
    93
    can you tell me the culture (locale) the OS runs in?
    please ensure it is UFT-8 (update-locale LANG=en_US.UTF-8)
    pure 3CX install (as it is new nothing to use) and apt-get install again
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Novensca Adi Pradewa

    Joined:
    Aug 8, 2017
    Messages:
    5
    Likes Received:
    0
    this is my locale :

    root@BENOA:~# locale
    LANG=en_US.UTF-8
    LANGUAGE=
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
     
  4. smario

    smario Support Team

    Joined:
    Dec 14, 2016
    Messages:
    21
    Likes Received:
    2
    Hello,

    Tell me a little more about your setup.

    Is this a VM on hardware, in the cloud? Was is installed via our ISO?

    What exact version of Debian are you using? You can type "lsb_release -a" to check.
     
  5. Novensca Adi Pradewa

    Joined:
    Aug 8, 2017
    Messages:
    5
    Likes Received:
    0
    yes, i'm install from your ISO.

    this version of my OS :
    root@BENOA:~# lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 8.9 (jessie)
    Release: 8.9
    Codename: jessie
    root@BENOA:~#
     
  6. smario

    smario Support Team

    Joined:
    Dec 14, 2016
    Messages:
    21
    Likes Received:
    2
    Where did you install it on? A virtual machine in the cloud, on your desktop, on physical hardware?
     
  7. Novensca Adi Pradewa

    Joined:
    Aug 8, 2017
    Messages:
    5
    Likes Received:
    0
    I'am install on Hyper-V windows server 2008
     
  8. smario

    smario Support Team

    Joined:
    Dec 14, 2016
    Messages:
    21
    Likes Received:
    2
  9. Novensca Adi Pradewa

    Joined:
    Aug 8, 2017
    Messages:
    5
    Likes Received:
    0
    I'am already following the instruction but still error like this.
     

    Attached Files:

Thread Status:
Not open for further replies.