Error During Debian Package Update

Discussion in '3CX Phone System - General' started by mbwmbw, Oct 21, 2017.

Thread Status:
Not open for further replies.
  1. mbwmbw

    Joined:
    Oct 21, 2017
    Messages:
    2
    Likes Received:
    0
    I am attempting to update the system and running:
    sudo apt-get update && sudo apt-get upgrade

    Any idea what is going on here? I'm getting this error below saying http is not supported for the 3cx downloads?

    Get:11 http://cloudfront.debian.net jessie/contrib Translation-en [38.3 kB]
    Get:12 http://cloudfront.debian.net jessie/main Translation-en [4,582 kB]
    Get:13 http://cloudfront.debian.net jessie/non-free Translation-en [72.1 kB]
    Fetched 11.7 MB in 3s (3,376 kB/s)
    W: Failed to fetch https://downloads.3cx.com/downloads/3cxpbxexpress/Packages Protocol "http" not supported or disabled in libcurl

    E: Some index files failed to download. They have been ignored, or old ones used instead.
     
  2. eddv123

    eddv123 Well-Known Member

    Joined:
    Aug 15, 2017
    Messages:
    1,218
    Likes Received:
    174
    Have a Google search for the error you are getting "Protocol "http" not supported or disabled in libcurl" have a read through there is some useful information in regards to this error and from what I can see several potential fix's to your issue:

    https://unix.stackexchange.com/ques...p-not-supported-or-disabled-in-libcurl/393346
    https://discuss.newrelic.com/t/curl-https-not-supported-or-disabled-in-libcurl/43204
    https://askubuntu.com/questions/821186/protocol-https-not-supported-or-disabled-in-libcurl
     
  3. Glen Atkinson

    Joined:
    Oct 31, 2017
    Messages:
    1
    Likes Received:
    0
Thread Status:
Not open for further replies.