Errors, no incoming audio, etc. since upgrade to June Build

Discussion in '3CX Phone System - General' started by Mirzab, Aug 2, 2007.

Thread Status:
Not open for further replies.
  1. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    I have a couple of questions if I might:

    I upgraded yesterday to the 17th June release and since then have been suffering from no audio on incoming calls, outbound works fine. Sample of errors if relevant from log:

    12:08:57.917 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    12:08:57.897 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"

    In over a month of prior use I have never encountered these errors and other than the actual upgrade, have not made any other changes of any type. System is being used with vBuzzer as provider and two PAP2's for four analog extensions.

    All ports identified in this forum has been forwarded from the inception of the original install. No stun server entries, using (I believe) the default(s).

    My second question pertains to verifying version installed - on the web interface it says "3CX Phone System Version3.0.2328.0" though the upgrade I did should have been to current build. How do I check version?

    Earliest possible assistance would be appreciated since this system is now my sole method - it was very stable and dependable until now.

    Thanks.

    P.S. Can I download and re-install the prior build?
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    3CX Phone System Version3.0.2328.0 is the current version. All works fine for me.

    Do you have system backup before upgrade to Version3.0.2328.0? If yes. I recommend to re-install this version again than re-install the previous build.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    I am afraid through stupidity I never considered a backup prior to upgrade, age maybe. Ongoing errors from log:

    14:09:22.826 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    14:09:22.816 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"
    13:56:58.996 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    13:56:58.986 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"
    13:41:58.211 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    13:41:58.201 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"
    13:39:40.663 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    13:39:40.653 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"
    13:39:38.771 DBPostgressAccessor::addRegistrarContact ERROR: invalid page header in block 131 of relation "prstorage"
    13:39:38.761 DBPostgressAccessor::removeRegistrarContact ERROR: invalid page header in block 5 of relation "prstorage"

    Can anyone help me identify and fix?

    Thanks.
     
  4. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Database problem.
    which version did you upgrade to 2328?
    If you have database backup then install 2328 from scratch and restore database. If you don't have it then provide information for support team regarding how did you upgrade your version and about main points of previous configuration of PBX.

    Thanks,
    Stepan
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    Thanks for the prompt replies everyone. A couple months back I downloaded whichever version was available, the only thing I am fairly sure of was that I did the download before 17th June. I installed and since then was progressing fairly well on my learning curve. Just two days back I noticed the subject of the latest release and in my infinite stupidity, without any backup, I downloaded the upgrade and ran it. Rebooted after as it required and all seemed well. Only this morning I began to get numerous complaints of no audio inbound on about 50% of calls. I checked server log and only error was the one I listed here - I have no clue if related to audio problem but seems too much of a co-incidence. So if I understand correctly my best option is un-install then install new?
     
  6. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Well, I would suggest you to make backup NOW, than uninstall and install again, than import your backup.
    Your problem is that new (June) version introduced new feature - persisten storage of registrations in database. But it seems that your database structure hasn't been updated during upgrade. Don't know why, though. Anyway, it should be fixed if you make clean install, and having backup allows you to quickly restore current settings.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    Looks like I am in trouble no matter which way you slice it, backup will not run, log below:

    Error getting data from table gateway: ERROR: current transaction is aborted, commands ignored until end of transaction block
    #0 C:\Program Files\3CX PhoneSystem\Data\Http\functions\BackupManager.php(771): safeExec(Object(PDOStatement), 'Error getting d...')
    #1 C:\Program Files\3CX PhoneSystem\Data\Http\functions\BackupManager.php(95): BackupManager->dumpTable('gateway')
    #2 C:\Program Files\3CX PhoneSystem\Data\Http\backup.php(28): BackupManager->doBackup(1)
    #3 C:\Program Files\3CX PhoneSystem\Data\Http\backup.php(2): phpshield_load('AAQAAAAKAAAABGg...')
    #4 {main}

    I am setting up a clean install on another machine and will replicate everything the hard way. Then hopefully with it running in place as a backup server, I can re-install and use a backup from that to restore easily. At least this way I will have learnt the backup lesson very well.
     
  8. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    Success at Last!

    Just to conclude this thread - After some intensive work recreating the Server setup on a separate Win2K machine (just to preserve the existing call ability as long as possible) and swapping the analog adapters over, I was able to un-install and then fresh install current build. I tthen backed up the Server I had recently created and "restored" from that file on the new installation - worked like a charm in seconds. A little bit of work switching back adapters and all works fine now.

    Single observation that I will copy over to appropriate thread - NEEDED: AUTOMATE BACKUP FEATURE and ensure it can save to a network drive without requiring additional input.

    Thanks everyone.
     
Thread Status:
Not open for further replies.