Solved Even better User Experience with the latest 3CX Client for iOS

Discussion in 'iOS' started by LeonidasG, Jul 26, 2017.

Thread Status:
Not open for further replies.
  1. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,406
    Likes Received:
    81
    Continue reading the Original Blog Post.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    jed likes this.
  2. Stephen Lilly

    Joined:
    Sep 24, 2017
    Messages:
    3
    Likes Received:
    0
    Hi
    It seems the iOS version does not work with ios11 ?
    Is there a fix or are you discontinuing this product ?
    Thanks
     
  3. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,444
    Likes Received:
    61
    We have no complaints so far about our client running on iOS 11. Can you provide us some extra information?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Stephen Lilly

    Joined:
    Sep 24, 2017
    Messages:
    3
    Likes Received:
    0
    Hello
    Thank you for your reply, please see attached screen shot i am seeing

    Kind Regards
    Stephen
     

    Attached Files:

    • 3CX.jpg
      3CX.jpg
      File size:
      102.6 KB
      Views:
      12
  5. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,444
    Likes Received:
    61
    Hi Stephen

    Wow, I didn't expect that! Now I understand, you have a very old version of our client (I'm assuming it's our first, generic SIP client) which we no longer develop/support it since long time ago and indeed should not be compatible with iOS 11. What version is?

    Thanks
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Stephen Lilly

    Joined:
    Sep 24, 2017
    Messages:
    3
    Likes Received:
    0
    Hi
    Im unsure of its version, as i'm unable to get passed this screen - its been installed for many many years and has worked flawless..

    I do have 1.1.5 installed on a old phone

    Is there something else i should now consider ?

    Kind Regards
    Stepehn
     
  7. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,444
    Likes Received:
    61
    Stephen, unfortunately - no. Basically, we discontinued that version about four years ago. At that time, there were only 32-bit builds, but now, starting with iOS 11, Apple no longer allow them, it requires 64-bit only, that's why iOS display that message box you saw. Strictly speaking, since we no longer develop it, the only solution to use it is to run it on an IOS < 11, there is no other way.
    Sorry for inconvenience
    vali

    P.S I'm assuming you used it as a generic SIP phone, connected to a VoIP provider or a different PBX than 3CX Phone System. In case you use a 3CX Phone System, obviously I highly recommend you to use the latest, 3CX-compatible only client, version
    https://itunes.apple.com/us/app/3cx/id992045982?mt=8
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #7 Vali_3CX, Sep 30, 2017
    Last edited: Sep 30, 2017
Thread Status:
Not open for further replies.