Excessive Sessions by Skype causing network failure

Discussion in '3CX Phone System - General' started by Jonners59, Sep 2, 2009.

Thread Status:
Not open for further replies.
  1. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Since installing the SkypeGW with 3 accounts on it, my Server is running huge amounts of sessions, so much so that my ISP blocks access, so I have to resort to a router re-boot. This makes the 3CX useless, as calls can not come in or out and the only way of knowing is when logged on to my PC and trying to browse the internet.

    Can anyone help me?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    Can you provide some more information about your system?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    Make sure your system is not acting as a Skype Supernode. This will cause a lot of connections.

    Info on Supernodes.

    Code:
    Skype uses peer-to-peer communications in order to allow users to find one another. Consequently, a small percentage of our users will hold a record reflecting the online presence of other users. When one user holds a record concerning the presence of other users, the former is called a "supernode", or directory node.
    
    Even though the traffic sent to supernodes is negligible, some institutions are interested in preventing users on their network from becoming supernodes and, thereby, answering directory enquiries for other users.
    
    There are several ways to prevent Skype from becoming a supernode:
    
    ◦Beginning with Skype 3.0, an explicit switch is provided in the registry settings to allow the disabling of supernode functionality.
    ◦Any computer hosted on a network that is behind a network address translation (NAT) device or restrictive firewall will disable supernode functionality.
    ◦Skype clients behind an HTTP or SOCKS5 proxy will not serve as supernodes.
    Enterprises typically opt for using the registry setting technique for turning off supernode functionality, simply because it is very straightforward to deploy a Windows GPO that contains the appropriate registry key setting. However, universities often find this more problematic because the computers may not be owned or operated by the host institution, making it difficult or impossible to ensure that registry keys are set properly.
    
    In these cases, it may be more useful to set up a SOCKS5 proxy. Skype can be configured to use a SOCKS5 proxy, regardless of whether the client finds itself on a network with a public IP address or on one with a private IP address.
    
    While the use of a SOCKS5 proxy still requires manual intervention by the user, the use of a proxy allows the economical "shaping" of Skype traffic. It has the additional positive side-effect of reducing supernodes on the network, reducing false-positive intrusion prevention system alarms and allowing for accurate measurement of Skype usage on the proxied network.
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    Danny
    This is great. I asked Skype themselves and they gave a very vague answer and suggested the comercial version but not how to configure it.

    I have since deactivated the 3CX Skype Gateway and the sessions just disaperaed and the DSL stays up, so my hunch was right. I do have other concerns with the tool, whilst a great one in principle I am not able to get outbound calls and use the Skype functions from within the 3CX environment, so can't see me being able to get the wife to convert. That said, I like a challenge, so willing to have another bash.

    I have not set up a SOCKS5 before. I have found the settings in Skype. It requires a PROXY Server address and PORT. Where would I find these? Sorry if this is a daft question.

    Regards
    Jonners
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    The easiest way to see if this is your issue is to turn it off via the registry then test.

    HKEY_LOCAL_MACHINE\Software\Policies\Skype\Phone, DisableSupernode, REG_DWORD = {0,1}
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    Hi Danny
    I had turned off my Skype Gateway and Skype in general too and the sessions stopped straight away. I have just decided to try out your Reg solution. I have been searching Regedit for hours and can't find the entry to which you refer.

    There are two types of Skype - I have since discovered - the Personal and the Business. I am guessing the entry you refer is for the Business as that has greater cointrol. I have downloaded it, but unsure about installing as it means rebuilding everything again no doubt.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    You will need to create it if it does not exist. Here is the administrators guide with more options.

    http://www.skype.com/security/network-admin-guide-version2.2.pdf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    Cheers Danny
    I have had a go. This is my first Regedit, but I am not getting whjat I thought I might.
    I used Regedit to find where the entry should be

    I then created a file by right click and selecting "NEW" "key" and renaming it Skype.
    I did the same again to craete "Phone".
    Then within "Phone I right clicked and created "NEW" "DWORD (32-bit) value". I renamed it "DisableSupernode"

    I believe that so far this is all correct - please confirm

    Then I selected data and have tried to type 01... then tried 0.1 then tried 0 in 1st space followed by a 1 at the end... each time it states "(invalid DWORD (32-bit) value)" How should I enter {0,1}, please?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    Re: Excessive Sessions causing network failure

    The options are '0' or '1' not both. So to DisableSupernode set it to 1
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Jonners59

    Jonners59 New Member

    Joined:
    Apr 21, 2009
    Messages:
    129
    Likes Received:
    0
    I'm sure I'm doing this wrong. It seems to make no difference. Tried on 3 machines now.

    Do you have screen shots?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.