Exchange Unified Messaging 403 Forbidden

Discussion in '3CX Phone System - General' started by extrascope, Jan 31, 2010.

Thread Status:
Not open for further replies.
  1. extrascope

    Joined:
    Jan 31, 2010
    Messages:
    4
    Likes Received:
    0
    Hi, I have followed all the instructions in the official manual for setting up unified messaging on Exchange 2007/2010 with 3CX.

    However, when calling 999 for voicemail 3CX reports the following logs:#

    20:00:18.826 [CM503003]: Call(37): Call to sip:MNU@192.168.0.221:5060 has failed; Cause: 403 Forbidden; from IP:192.168.0.221:5065

    192.168.0.221 is my exchange server

    The exchange server reports the following error:

    The unified messaging server rejected a call with incoming call with the ID ###ID###. Reason: The unified messaging server has recevied an incoming call with a SIP URI "sip:MNU@192.168.0.221:5065;transport=tcp". That's not valid for dial plan "3CX".

    Any help to get this working would be very appreciated. The error seems to be saying that the dial plan is not allowing it but I have checked everything.
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,400
    Likes Received:
    79
    First of all, do you test 2007 or 2010 Exchange Server?

    Issue is that the Exchange takes your call and moves it to the next port 5065.
    So the connection from 3CX to Exchange is fine.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Hi

    You need to use version 8.0.10824 available from here for Exchange 2010 to work.

    http://www.3cx.com/downloads/3CXPhoneSystem8_8.0.10824.exe

    basically for 2007 the invite was sent in the format MNU@....
    But this in 2010 is not accepted and ex 2010 needs a number there.

    So in the last update we made it in 2010 format which happens to be also compatible with 2007.

    Uninstall and install the latest version and try again.

    If you still fail, then the problem is in your configuration of exchange and follow the guide on the wiki which has a description of how to configure Exchange 2007 and Exchange 2010 (Everything is exactly identical except for 1 single point.)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. welsh

    Joined:
    Mar 17, 2009
    Messages:
    18
    Likes Received:
    0
    I'm having a similar issue, Exchange 2010. My 3CX system is on v9.15536. Any ideas?
     
  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    the error you are getting is not related to the original post - this post is old.

    You need to troubleshoot exchange and check event viewer and see what is the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. welsh

    Joined:
    Mar 17, 2009
    Messages:
    18
    Likes Received:
    0
    Well... turns out that my issue related to upgrading from 2007 to 2010. I needed to re-add the custom greeting files.
     
Thread Status:
Not open for further replies.