Extension Move to Another Network

Discussion in '3CX Phone System - General' started by johnmichael, Jun 30, 2014.

Thread Status:
Not open for further replies.
  1. johnmichael

    Joined:
    Apr 6, 2010
    Messages:
    48
    Likes Received:
    0
    Hi Guys,

    I would like to seek some advice with regards to our issue as I am currently quite confused with the type of setup.

    I recently move one of our extension (Linksys SPA901) to our remote office that it is connected through a VPN tunnel. The setup is exactly the same as "Public Network – VPN" on this link http://www.3cx.com/blog/docs/network-configurations-supported-3cx-phone-system/

    The provisioning went fine and we are able to call internal to internal but the problem is that there is no audio if the the call is from external to internal or internal to external. Firewall (watchguard) policy has been set to allow any to any from Net A <==> Net B.

    My question is that, is there any other configuration that we need to fix the problem?


    Thanks in advanced guys.
     
  2. intellegens

    Joined:
    Jun 19, 2013
    Messages:
    18
    Likes Received:
    0
    Have you run the firewall checker? Does it come back clean?
    Do you have NAT rules in place to make sure 3CX related traffic can get to the PBX from the Internet side?
     
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Is the SIP ALG turned off in the router?
     
  4. johnmichael

    Joined:
    Apr 6, 2010
    Messages:
    48
    Likes Received:
    0
    @intellegens and @ lneblett,

    thanks for the valuable input guys and I believe both of your suggestion are right.

    though we've allowed normal traffic on the firewall but I think we miss allowing traffic for VoIP, which is something to do with SIP ALG.

    We'll check this out and will update here again.

    Thanks again everyone.
     
  5. johnmichael

    Joined:
    Apr 6, 2010
    Messages:
    48
    Likes Received:
    0
    Hi Guys,

    Sorry for the late reply. I haven't added any reply as we are still working with this issue.

    Initially, SIP ALG on WatchGuard is disabled but even if we enabled it and add policy it is still not working.

    Hope there is someone who managed to make this work on a WatchGuard firewall that can suggest on how they did it, It would be appreciated.

    TIA,

    John
     
  6. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Have you checked pbx delivers audio as well? maybe using SBC would be the best route to take here.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Based on you original post, you have a site to site VPN. If that is the case, you need to configure your endpoint as if it was on the same LAN as the server. Meaning, your SIP server address will be the PRIVATE one and not the public one (192.168.x.x/172.X.X.X/10.X.X.X likely).

    This again assumes that you are on a routed site to site VPN. This avoids all NAT related issues
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.