Extension Outbound CallerID

Discussion in '3CX Phone System - General' started by Jonathan, May 29, 2008.

Thread Status:
Not open for further replies.
  1. Jonathan

    Joined:
    May 15, 2008
    Messages:
    11
    Likes Received:
    0
    I would like to pass the "Extension Outbound Caller ID" to the "Gateway/Provider Outbound Parameters"::"Remote Party ID - Calling Party : User Part" field.

    Does anyone know what fieldName contains the Extensions Outbound CallerID
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    I also want to know how to send extension number as e164 calling ID as well. V3 - the default setting is done. However, this setting disappear after v3.1.

    There is not found any valuable contains the extension number at "Gateway/Provider Outbound Parameters".

    The workaround is put your outbound id as extension number. Then set up :
    Gateway / Provider Outbound Parameters
    From : User Part => Value select CallerName instead of CallerNum

    IMPORTANT: According to 3CX support, this is a wrong setting. But we have no other choice. Set it as your OWN risk.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Jonathan

    Joined:
    May 15, 2008
    Messages:
    11
    Likes Received:
    0
    Telasip our VoIP provider uses the Remote Party ID for OutboundCallerID so i would like use the OutboundCallerID field that is under Extension=>Other Options.

    I am assuming that the value held in the OutboundCallerID can be passed to the remote party ID of the providers outbound paramaters either through a pre-set field or custom field - just need to know how.

    3CX Phone System Version5.1.4510.0
     
  4. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    You need to adjust Outbound parameters for your provider(/Gateway?)
    Make sure proper RemotePartyID definition has non-empty host/port part. If your provider doesn't care about this part - you better use Custom value like "192.168.1.1:5060"
    Than set user-part of that header to be $CallerName. But be careful. Do NOT put $CallerName to any other header's user-part. Otherwise you may experience problems with call transfers, etc.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Jonathan

    Joined:
    May 15, 2008
    Messages:
    11
    Likes Received:
    0
    That appears to be working.

    Thank you very much :lol:
     
Thread Status:
Not open for further replies.