Extensions call each other but no sound

Discussion in '3CX Phone System - General' started by Anonymous, Oct 26, 2006.

  1. Anonymous

    Anonymous Guest

    I've just downloaded this phone system and installed it.

    The install was a breeze compared to the linux ones I've been trying to get working over the last few days!

    I have one slight problem: My extensions appear to be registered fine, (Grandstrem bt101s). When the ring each other though, it rings but when you answer it there isn't any sound at all...

    Any ideas?
     
  2. Anonymous

    Anonymous Guest

    incidentally I'm not using any of the outside dialing features, and I can use the direct IP dial features on the phones without any problems.
    It's only when I try to use the pbx that there's an issue.

    Is there a particular phone protocol I should use?
     
  3. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Hi,

    Thanks for your positive comments!

    From the description of your problem it seems as if RTP is not working, but SIP is. When you use the PhoneSystem you will have RTP going through different ports, in contrast to when you do a direct IP call. Is there any sort of fiewall in the middle blocking the RTP ports?
     
  4. Anonymous

    Anonymous Guest

    They're all attached to a NAT router, but they're all inside it, so that shouldn't be causing any problems.

    I've tried another pbx called axon, and that one (just typing in the extension details into the pbx, not changing any settings on the phones) works now and again, by which I mean I can dial other extensions, and if it puts me through then I'll have sound. More often than not though it doesn't put me through... (probably poor software!)

    I've also tested a sip server called brekeke, and that one registers all the phones and allows perfect calls between. Obviously though it's not a pbx, so I would still like to fix this.

    So it appears to be something to do with my software setup on the 3cx side, rather than any local settings. At least, that's the impression I'm getting.
    I've tried two different pcs, but still no joy with it.

    It's running on windows 2000, and I'm not getting any errors showing in the log files.

    Any suggestions as to where I might look next?
     

Share This Page