Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Extensions not becoming Available Automatically with office hours {Re-Opened}

Discussion in '3CX Phone System - General' started by roadwings, Jul 13, 2016.

Thread Status:
Not open for further replies.
  1. roadwings

    Joined:
    May 16, 2015
    Messages:
    49
    Likes Received:
    14
    Yesterday and today the extensions have not automatically changed back to Available when our office has opened. They did however automatically go to DND at closing time. Before the upgrade from 14 SC2 to 15 they would go to away at closing and available at opening. Office hours are set and extensions are flagged to automatically change with office hours.

    Pro SC16, Yealink T38G and T48G. Also where do I verify my DHCP option 66 provisioning path according to 3CX? I feel that that address may have changed a bit. I cant find where it tells the admin that URL.
     
  2. tratz

    tratz New Member

    Joined:
    Oct 21, 2015
    Messages:
    111
    Likes Received:
    16
    Re: Extensions not becoming Available Automatically with office hours

    If you click on an extension and go to provisioning. Look at an ip phone and it will show you the provisioning url.

    --Tracy
     
  3. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Re: Extensions not becoming Available Automatically with office hours

    Elaborate more about profile changing please, is it possible we can see some sort of log, contact me via PM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. roadwings

    Joined:
    May 16, 2015
    Messages:
    49
    Likes Received:
    14
    Re: Extensions not becoming Available Automatically with office hours

    I looked through the log entries at opening time 09:00 and nothing shows up. No error messages or informative entries. The extensions are not automatically set to Available like they used to. But the system did just put them all to 'DND->FWD to VM' at closing time a few minutes ago. I will turn on verbose logging tonight. Let me know what log to check in the morning after we open again.
     
  5. ucs1

    Joined:
    Jun 21, 2013
    Messages:
    42
    Likes Received:
    1
    Re: Extensions not becoming Available Automatically with office hours

    Are you using the release version of v15. I had this issue in RC2 and it appears to be fixed with the v15 Release.

    I imagine you also have "Auto Switch" enabled under forwarding rules for each extension also?
     
  6. roadwings

    Joined:
    May 16, 2015
    Messages:
    49
    Likes Received:
    14
    Re: Extensions not becoming Available Automatically with office hours

    All extensions became available and logged into their queues today. All I did was set the logging to verbose and reboot.
     
  7. roadwings

    Joined:
    May 16, 2015
    Messages:
    49
    Likes Received:
    14
    Thursday AM, Extensions did not automatically become available or log in to queues. Pretty random. What log should I look in?
     
  8. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    So the log you need to investigate is 3CXSystemService.log which ideally if set to Verbose you will see the full picture of what is going on.

    2016/07/22 09:26:55.640|3548|0003|Info|UpdateOrInsert schedule for 100
    2016/07/22 09:26:55.676|3548|0003|Info|Next trigger for 100 at 2016-07-22 06-30-00

    Edit an extension which is causing this issue and see the log, stay track of what is going on.

    Very strange btw remember that the time will be in UTC..

    Let me know about this please.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.