External clients cannot connect because of wrong STUN provisioning

Discussion in '3CX Phone System - General' started by decalabs, Mar 29, 2017.

Thread Status:
Not open for further replies.
  1. decalabs

    Sep 21, 2016
    Likes Received:

    it worked before, but after some of the last 3CX updates it is not possible anymore for external clients to connect to our 3CX. Desk phones, Windows Apps and phone apps are not working outside our office.

    After some research I discovered the following in the provisioning files:

    SIP Server: pbx.company.tld
    SIP Port: 5060
    STUN Server: pbx.company.tld:5060

    So if I delete the STUN-Entry in the clients manually, everything works fine. Is there a config option in the Management Console for that?

    We have a fixed ip, so in the network configuration I chose "Static Public IP (IP Address does not change)" and no STUN.

    Any help would be greatly appreciated.

  2. Panayiotis_3CX

    Panayiotis_3CX Support Team
    Staff Member 3CX Support

    Apr 26, 2017
    Likes Received:
    Hello @decalabs,

    Have you tried the Firewall check in the PBX and received no errors? Also, under extension > Options you can try disabling the "Disallow use of extension outside the LAN" parameter. Also try enabling the "Use the 3CX tunnel when out of the office" in the client account.
    In addition, you can check if your FQDN resolves to your public IP.
Thread Status:
Not open for further replies.