External connections to 3CX won't maintain presence

Discussion in '3CX Phone System - General' started by Gerald Warren, Nov 13, 2015.

Thread Status:
Not open for further replies.
  1. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    Greetings!

    We have recently implemented a 3CX phone system in our company with Yealink T23G phones. We've worked out many internal issues, however still have an issue with external connections.

    To date, any 3CXPhone mobile or desktop client I have attempted to connect back to the 3CX system will display a constantly alternating "Connecting" and then "Time Out" in the presence field of the application. The 3CXPhone shows as on hook, but the presence window, voicemail, call history etc. are all blank. Additionally, the ports for Apple and Google push fail when running the firewall checker from the 3CX phone system, even though the ports are open within the WatchGuard firewall policy for 3CX.

    Any help on this would be greatly appreciated.
     
  2. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    0
    The "call control" component is using SIP.. UDP 5060.
    The "presence" component is using whatever your web service is set to.. TCP 80/5000. If that isn't forwarded/allowed, you'll get registration but no presence.

    Similar when UDP 9000-90xx isn't forwarding/opened and you get no media (typically no audio) coming in.
     
  3. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    Ian,
    Thanks for the reply.All those ports are set to be open for the 3CX firewall policy.
     

    Attached Files:

  4. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    Any further help on this would be greatly appreciated!
     
  5. CentrexJ

    CentrexJ Member

    Joined:
    May 5, 2009
    Messages:
    385
    Likes Received:
    52
    check windows firewall. 3cx doesn't always open up all the required ports on install.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    281
    Likes Received:
    22
    Check if your firewall has SIP ALG enabled. If so, then disable.

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Which version of 3cx are you using? Do you have the Yealinks set to keep alive?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    Verified that Windows Firewall on the 3CX PC is disabled.
     
  9. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    The WatchGuard software doesn't have a global SIP ALG setting. It has to be set up within a firewall policy and I do not have a policy with this setting enabled.
     
  10. Gerald Warren

    Joined:
    Oct 22, 2015
    Messages:
    19
    Likes Received:
    0
    3CX ver 13 SP1 build 45826.228

    I'm unsure if the Yealink are set to keep alive, but the issue is with the 3CXPhone app on iPhones and computers when they attempt to connect outside of the office LAN or BOVPN.
     
Thread Status:
Not open for further replies.