Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

External Extension Loses registration

Discussion in 'Windows' started by webby, Dec 10, 2009.

Thread Status:
Not open for further replies.
  1. webby

    Oct 20, 2009
    Likes Received:
    I have been using Grandstream GXP 2000 & 2010 pones internally no problem with Voip unlimited here in the UK and all has been excellent.

    However I have 2 x Grandstream GXP 2000 External Extensions, and these i can get connected and they work PERFECTLY for everything internal calls external calls incoming outgoing excellent UNTILL the ip address changes at the external site then they loose connection.

    Nothing in particular seems to re-connect them ( re-boot does nothing) jiggle some of the settings a bit and finally they will go again but only until the ip changes.

    I thought Stun was supposed to solve this sort of thing?

    Am i missing something?

    My set up:
    IPPBX has a static External ip address and and static internal ip address.
    I have set the Sip server and outbound proxy to this address in my external phones
    The external phones have a dynamic external ip address and a fixed internal ip address all ports are forwarded and as i say i will work perfectly until the ip changes.

    Any ideas!?
  2. leejor

    leejor Well-Known Member

    Jan 22, 2008
    Likes Received:
    How often is the "remote" public IP changing??? I have a couple of dynamic IPs but as long as the routers are powered it can be as long as six months before getting a new IP. It sounds like you have STUN set up on the phones at the remote location, you should. If the IP changes that often then it is understandable that you are having problems,I'd be asking my ISP why that is happening.

    The sets may not be making a STUN test often enough (only at startup?), perhaps that can be adjusted to a shorter interval. You might also try shortening the registration time to below the 30 minute (3CX) default.
Thread Status:
Not open for further replies.