External Extension on Linksys SPA942

Discussion in 'Windows' started by sinboo50, Mar 16, 2009.

Thread Status:
Not open for further replies.
  1. sinboo50

    Joined:
    Feb 28, 2009
    Messages:
    25
    Likes Received:
    0
    I have an external extension working fine using the current VOIP Softphone. I am having trouble getting the extension to register on the Linksys SPA942. I have viewd the 3CX videos on the topic but I must be missing something.

    SIP Settings
    Stun Server = stun.3cx.com
    enable stun = yes

    My line configuration is attached:

    Also is it necessary to run the proxy client at the same time? I do have that running.

    Thanks in advance.. I know this is elementary but I am a newbie.

    Cheers,

    Bruce
     

    Attached Files:

  2. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi
    I aslo have been having the same problem using a Linksys SPA-921 & 942, soft client works fine, but registration fails on hardware, therefore I would also like to hear from anbody who has this type of setup working.
     
  3. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi Bruce
    After many hours I have cracked it,
    EXT no.

    SIP Settings
    SIP Transport: TCP
    SIP Port: 5060
    SIP Proxy-Require: Local IP address of 3CX server

    Dial Plan do not alter

    This config registered immediately for me and allowed me to call extensions within our office.
     
  4. sinboo50

    Joined:
    Feb 28, 2009
    Messages:
    25
    Likes Received:
    0
    Still working on it here....

    Are you using the current softphone client or just the tunnel client?
     
  5. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi
    I am using the "Direct" connection as opposed the "Tunnel" in the 3cx voip client.
     
  6. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    Hi Pruce
    change stun server to another stun server like stun01.sipphone.com
    change preferred codec to g729 in all your devices
     
Thread Status:
Not open for further replies.