External Extensions not fully working

Discussion in '3CX Phone System - General' started by jduncan, Jan 10, 2008.

Thread Status:
Not open for further replies.
  1. jduncan

    Jul 26, 2007
    Likes Received:
    Hi all, i am sure this is a double-post and for that i apologize but i cant find this specific problem anywhere.

    I am using 3CX Phone System Version 3.1.2434.0. This sits in the DMZ on a DSL connection with DynDNS hostname configured on the router pointing it directly to the server. I can access the server fine remotely and even register external extensions using Eyebeam, X-Lite, 3CX VoIP Client and any other softphone i have tried. I can also register any of the hardphones i have tried including the Grandstream BT-200, HT-486 and the GXP-2000.

    The problem is this: I can call an extension using the remote softphones and speak to anyone connected locally to the 3CX server. I can also call any other remote softphone and it works fine.
    The hardphones, however, connect without issue, make the calls but when you pickup there is no audio either way. It is the same thing no matter what is called. Even if it is a local softphone, local hardphone or remote soft/hardphones. It simply does not work.

    If i call the DR from the hardphone it works but only if i setup virtual server or place it in the DMZ. Without this i get silence. It still does not work for a call though. The softphones do not require any changes to be made on the router. STUN is configured in both the hardphones and the softphones. Here is the log of a phone call from one extension to another:

    11:27:21.052 MediaServerReporting::RTPReceiver [MS105000] Call(1450) Ext.309: No RTP packets were received on 00000B0B@:remoteAddr=,extAddr=,localAddr=
    11:27:21.052 MediaServerReporting::RTPReceiver [MS105000] Call(1450) Ext.310: No RTP packets were received on 00000B0C@:remoteAddr=,extAddr=,localAddr=
    11:27:21.052 StratLink::eek:nHangUp [CM104001] Call(1450): Ext.309 hung up call; cause: BYE; reason: SIP;description="User Hung Up"
    11:26:58.183 CallLegImpl::eek:nConnected [CM103001] Call(1450): Created audio channel for Ext.310 ( with Media Server (
    11:26:58.167 StratInOut::eek:nConnected [CM104005] Call(1450): Setup completed for call from Ext.309 to Ext.310
    11:26:58.167 CallLegImpl::eek:nConnected [CM103001] Call(1450): Created audio channel for Ext.309 ( with Media Server (
    11:26:50.414 CallConf::eek:nProvisional [CM103003] Call(1450): Ext.310 is ringing
    11:26:50.024 CallConf::eek:nIncoming [CM103002] Call(1450): Incoming call from 309 (Ext.309) to sip:310@fcl-teleaxis.webhop.net
    11:26:18.262 ServRegs::eek:nAdd [CM113002] Registered: Ext.310
    11:26:14.050 ServRegs::eek:nAdd [CM113002] Registered: Ext.309

    Any help on this issue is GREATLY appreciated. Thanks in advance.
Thread Status:
Not open for further replies.