External FQDN

Discussion in '3CX Phone System - General' started by dajonx, Sep 12, 2017.

Thread Status:
Not open for further replies.
  1. dajonx

    Joined:
    Nov 19, 2015
    Messages:
    18
    Likes Received:
    0
    Hi,

    I have been wrestling with 3CX all week and I think I have figured out most of the issues. There is one issue that I have no idea how to resolve.

    I have 3CX 15.5 installed on a VM and it's working for the most part. I did encounter a user that attempted to join a conference call receive the error message: "Call failed, declined". It was trying to register with the external FQDN when the call is within the office VPN. Is there a way to turn off the external FQDN?

    Thank you!
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,003
    Likes Received:
    198
    Hello @dajonx

    Are you using a 3CX client or an IP phone? If it is a phone it it provisioned as local in the management console? Can the phone reach the PBX through the VPN? Are you referring to an audio call or a video call?
     
  3. dajonx

    Joined:
    Nov 19, 2015
    Messages:
    18
    Likes Received:
    0
    Hi Yiannis!

    The user is using a 3CX softphone client on his Windows 10 laptop with a headset. We have sent him a 3CX Welcome Email from the Management Console and it was executed. Yes, I'm pretty sure the softphone client can reach the PBX through the VPN. And, it's an audio call.

    Thank you!
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,003
    Likes Received:
    198
    The client will try to connect to the local IP first and if no reply from the local IP it will switch to the out of office FQDN. Please make sure that the client can communicate with the PBX through the tunnel. Are you using a local IP and external FQDN or do you have a split DNS configuration?
     
  5. dajonx

    Joined:
    Nov 19, 2015
    Messages:
    18
    Likes Received:
    0
    I think all of the clients (softphone and VoIP phones) are configured to communicate to a CNAME DNS record. Since we had to create an external FQDN and IP, I'm not sure if that's messing things up.

    Here's an example of our configuration on the Mangement Console:
    FQDN: blah.east.3cx.us
    IP: 71.185.xxx.xxx (non internal IP address)
    Webmeeting FQDN: blah-east-us.3cx.net

    In the Cisco VoIP phone configuration, this is how it is set up:
    Proxy: <CNAME DNS record pointing to the 3CX VM IP>
    UserID: <extension number>
    Use Auth ID: No
     
  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    3,003
    Likes Received:
    198
    Does that CNAME address point correctly to the Local IP of the PBX? Can you resolve that CNAME from the clients side of the VPN? If you can then there should be no issue. You can also try a test, open a 3CX client and navigate to settings / configure accounts / edit the account and under "My Location" delete the value in the "Out of Office" field. Click ok, does the client still connect when you re-register?
     
  7. dajonx

    Joined:
    Nov 19, 2015
    Messages:
    18
    Likes Received:
    0
    Hmm... It looks like it works now.

    Thank you for your help!!
     
Thread Status:
Not open for further replies.