Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

External phone cannot make calls

Discussion in '3CX Phone System - General' started by muaddib32, Dec 20, 2010.

Thread Status:
Not open for further replies.
  1. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    I have installed the 3CX softphone on my iPhone and on a test computer outside the office network. Both connect and can receive calls but cannot make calls. There is a long pause after pressing the dial key, then it briefly displays 'calling' before going back on hook. All the correct ports appear to be open on the firewall (and the server passes the firewall check).

    Any suggestions?

    Ben
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi Ben,

    First things first, is the call reaching the PBX at all? And are you making the call over 3g or wifi? Can you confirm that the same is happening over wifi.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Hi Mark,

    This happens even with the softphone over cable. Any remote connection. Attached is the section of the activity log where I connect the 3CX phone remotely and then attempt to make a call. You can see it rejects the call. How do I fix this? It says something about adjusting the source identification (N.B. I have modified the outgoing number to 9439xxxx and the domain to domain.com.au).

    Regards,
    Ben

    -----------------------------------------------------------------------------------------------------
    20:57:16.221 Requests rate from IP 203.171.196.107 is too high! Blacklisted for 334 seconds
    20:57:16.221 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:9439xxxx@pbx.domain.com.au:5065 SIP/2.0
    Via: SIP/2.0/UDP 203.171.196.107:5060;rport=5060;branch=z9hG4bKPjhlobGrlFA5sj3LY.HWhLjN3BDF-fbnPW
    Max-Forwards: 70
    Contact: <sip:104@203.171.196.107:5060>
    To: <sip:9439xxxx@pbx.domain.com.au>
    From: <sip:104@pbx.domain.com.au>;tag=Cgawg3bFNnupVsMJ6zC4UyO-7JzjR27h
    Call-ID: sOZ7I-5sXlfczoXStCWLyoatYgTS5vOt
    CSeq: 20143 INVITE
    Session-Expires: 1800
    Min-SE: 90
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Supported: replaces, 100rel, timer, norefersub
    User-Agent: 3CXPhone for iPhone 1.0.18
    Content-Length: 0

    20:57:16.221 [CM302001]: Authorization system can not identify source of: SipReq: INVITE 9439xxxx@pbx.domain.com.au:5065 tid=PjhlobGrlFA5sj3LY.HWhLjN3BDF-fbnPW cseq=INVITE contact=104@203.171.196.107:5060 / 20143 from(wire)
    20:57:01.002 Currently active calls [none]
    20:56:54.784 [CM504001]: Ext.104: new contact is registered. Contact(s): [sip:104@203.171.196.107:5060/104]
     
  4. mhanson

    mhanson New Member

    Joined:
    Nov 6, 2008
    Messages:
    186
    Likes Received:
    1
    Are your phones set to register to pbx.domain.com.au?

    If so, have you added that hostname into the Local SIP domain?

    Go to Settings => Advanced and in the "Settings for Direct SIP Calls" and enter that Hostname into the Local SIP domain field.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Aha, that fixed it. Thanks Matt.
     
  6. mhanson

    mhanson New Member

    Joined:
    Nov 6, 2008
    Messages:
    186
    Likes Received:
    1
    Glad to help. This is a somewhat common issue. You will always get a source ID error when a call is presenting itself to an address the system is not familiar with. Normally this happens when a call is coming through a VoIP provider and is being presented as TO: a number that is not authorized in the system.

    In this case, you were presenting a Host part of @pbx.domain.com.au:5065, when it was actually expecting it's own IP. By adding the local sip domain it allows presentation of that DNS hostname.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.