External problem

Discussion in '3CX Phone System - General' started by you2web, Sep 21, 2009.

Thread Status:
Not open for further replies.
  1. you2web

    Joined:
    Sep 21, 2009
    Messages:
    15
    Likes Received:
    0
    Hey,

    i am new to 3cx and i need some help installing and cofiguring software.

    My problem is following.
    I have setup 3 softphones and 2 hardware ip phones without the problem. ( everything works - locateted in same lan )
    In another office i have 2 hardware phones ( i am connecting to that office true VPN from main office where 3cx is installed - working good without problem )
    In another office i have 2 softphones and here is the problem: i dont use vpn to main office ) - on that location nothing works, no registration no nothing.

    I have read everything about firewall rules enabled everything but no luck. I even disabled firewall, but no luck

    I have vigor 2910iw on main office.

    Any help will be welcome.

    Thanks
    Uroš
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    There are a lot of variables involved when setting up external extensions. Does 3Cx even see a registration attempt from those extensions, even one that fails? Do you have STUN enabled on the extensions that aren't working? Are they behind a router?
     
  3. you2web

    Joined:
    Sep 21, 2009
    Messages:
    15
    Likes Received:
    0
    Thank you for replay
    Does 3Cx even see a registration attempt from those extensions, even one that fails?
    I think so - how can i check that


    Do you have STUN enabled on the extensions that aren't working?
    i dont understand what you mean with that - can you advice me with example



    Are they behind a router?
    All sides are behind firewall, stun port is enabled in office router, on other not

    I have attached picture from debug console ofn 3cxPhone soft ( link to that picture http://www.you2web.net/1.jpg )
     
  4. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    Please review this document;

    http://www.3cx.com/manual/3CXPhoneSystemManual31/phone-system17.html (Page 17)

    And open/forward the ports to your 3CX box and attempt again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. you2web

    Joined:
    Sep 21, 2009
    Messages:
    15
    Likes Received:
    0
    Thank you for replay,

    no luck with that, still doesnt work
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    If you look in the admin console of 3CX it will show whether or not the extensions are registered. They have to be or they just won't work. In the datafill for each set you can (or at least you should be able to) enable STUN and define a STUN server. That should be done for any external extensions, internal ones don't require that step. Make sure that you have all of the required ports forwarded in the router at the 3CX end. Make sure, that if there is more than one remote extension at a single location, behind a router, that you assign a unique port number to each one. the 3CX system logs will show you any attempts to register by all of the extensions, if you re-boot one of the remote extensions and don't see any log indication that it even got a registration attempt, then the messages aren't getting from the remote EXT, through your router, to 3CX. that will be the first obstacle to overcome.
     
  7. you2web

    Joined:
    Sep 21, 2009
    Messages:
    15
    Likes Received:
    0
    I have tried everything.
    Now i checked server log file and no recoreds of that external attamp of registration.
    Is it posiible to check ig STUN is availible for requests from outside the lan

    Thank you
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    The sets outside your LAN will use STUN (if you set it up) to determine what type of NAT they are behind. If 3CX isn't showing any indication of a registration attempt AND you are sure that the (3CX) public IP, port etc. is set up correctly in the remote extensions then you should probably be looking at your firewall/router. There is a good chance that the messages are being blocked. Did you set up port forwarding in your local router, the one that 3Cx attaches to?
     
  9. tpinnovations

    tpinnovations Member

    Joined:
    Jul 30, 2009
    Messages:
    296
    Likes Received:
    0
    You have set the phones to register with the external IP of the 3CX machine?

    If you are using the XML provisioning with your phones over NAT you will need to provision remote extensions by hand.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. houston

    Joined:
    Jul 21, 2009
    Messages:
    40
    Likes Received:
    0
    Not all phones can work as remote extenions over the public internet.

    If you want to side step the whole problem, as you are already working with VPN's, set up another to the remote office. Connecting over the public internet does add some additional complexity and imposes some extra requirements for everything to work correctly.
     
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    I can't quite see on your jpeg, what method you are trying to use to get back into the office. Have you tried using the tunnel option? You need port 5090 (i think that's the one) opened (forwarded) at the 3CX end router. And, of course you have to set up a tunnel password in 3CX.
     
  12. you2web

    Joined:
    Sep 21, 2009
    Messages:
    15
    Likes Received:
    0
    Thank you all for replay, i was managed to solve the problem
    I have used tunnel and now works

    Thank you all and sry for late respnce, i have been away

    Uros
     
Thread Status:
Not open for further replies.