External SIP phone - cannot answer call

Discussion in '3CX Phone System - General' started by hemant_mn, Aug 26, 2010.

Thread Status:
Not open for further replies.
  1. hemant_mn

    Joined:
    Aug 26, 2010
    Messages:
    7
    Likes Received:
    3
    All,

    I have a slight problem, which someone maybe able to help me with.

    I have a 3CX (latest build) setup with the advised ports open from the FAQ.

    Works fine on the internal network with the 3CX soft phone as well as a Snom 200 (old device I know, but still works with all VSPs that I have tried it with)

    Externally (home network), I am able to connect via the 3CX soft phone (w/ tunnelling protocol) and also with a 3rd party softphone using UPnP. Both these methods allow for inbound and outbound calls (2 way audio).

    The problem I face is with the Snom 200 from the external location. The device registers with the 3CX server (port forwarding is correct, as 3CX reports my external IP). I am able to make outbound calls to extensions and externals numbers via providers setup on 3CX (2 way audio).
    However when making inbound calls to my extension, the phone rings and I can answer the call (no audio)... however the calling end still shows as ringing the eventually times out/voicemail. (This is case with both, calls orginating externally and locally to/from the 3CX server)

    With regards to the Snom on the external network, it connects fine with other VoIP providers. In terms of ports, 5060 is obviously open as well a range for RTP (to note the RTP range is different from the range 3CX server has - so this is obvioulsy one thing I can change to try and resolve the issue)

    On another thread (http://www.3cx.com/forums/register-but-no-voice-on-unsupported-ip-phone-12490.html), it is suggested at the external end that port 5090 should be opened for the external phone - thoughts?


    TIA for any assistance on this matter.

    .h
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi ,

    First off you got the ports correct, 5060 is need for external extensions 5090 for tunnel. When working in an external location you have to take into acoount the "unknown". In other words what lies between your home network and your PBX. More often then not, while conductin a wireshark capture your will not the OK SDP does not reach the PBX, for whatever reason, therefore making the PBX think the call was never answered.

    1. Make sure your stun server is set properly.
    2. 5060 port is wide open ( try diabling your firewall aswell for a short whie).
    3. Run the firewall checker on yolur pbx ( Settings > firewall checker).
    4. If all else fails, tunnle you way to the PBX.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hemant_mn

    Joined:
    Aug 26, 2010
    Messages:
    7
    Likes Received:
    3
    Thanks for the response... I'll give those points a go...

    1. As far as I know it is... but I'll attempt to use the 3CX STUN server instead

    2. Presently working... but will attempt putting the phone on the public IP directly (No FW rules)

    3. Already completed successfully, reports back with no problems.

    4. Will attempt.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,749
    Likes Received:
    285
    What can sometimes happen, and the make of router can be the difference, is that the audio packets may still be directed towards another IP on your network. If you are going to use more than one device on the remote network be sure that each one has a unique ports number. One can be 5060 but the second one should have 5061 or 5062 and so on. If you placed a call from another device, say the 3CX phone (no tunnel) the router may still think that the voice packets are to be sent to it rather than the new VoIP device that you have now added. Try a reset on the router, usually just a power down, and then only try the one device, the Snom, and yes, you need to use STUN but other than response time (from the STUN server), it shouldn't make any difference which one you use. I have experienced one way audio problems when using a two port ATA, same IP, different port numbers for each port and each port is registered to a different 3CX server. one has no problem, but no audio incoming on the second port.
     
  5. hemant_mn

    Joined:
    Aug 26, 2010
    Messages:
    7
    Likes Received:
    3
    Thanks for the suggestions everyone. I have decided the Snom 200 just doesn't want to play nice with 3CX... (I tried all the suggestions made, still no joy).

    Have ended up setting up the remote connection (extension) on a PAP2 which works fine on answer.

    I'm sure I'll keep playing...
     
Thread Status:
Not open for further replies.