Failed to establish connection to 3cx phone system web api

Discussion in 'Windows' started by ummara, Jan 22, 2016.

Thread Status:
Not open for further replies.
  1. ummara

    Joined:
    Jan 21, 2016
    Messages:
    2
    Likes Received:
    0
    On start of 3cx phone, it gives,"failed to establish connection to 3cx phone system web api"
    and contacts and status in "presence " are not available.
    I configured spilt dns and have done configuration of external and internal FQDN.
     

    Attached Files:

    • 1.png
      1.png
      File size:
      25.8 KB
      Views:
      1,094
  2. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,367
    Likes Received:
    83
    Check out this thread, I think the problem might be very similar:

    http://www.3cx.com/forums/viewtopic.php?f=34&t=43819
     
  3. aktivtrans.cz

    Joined:
    Jan 24, 2016
    Messages:
    1
    Likes Received:
    0
    HEllo, I have same issue. Failed to establish connection to 3cx phone system web api.

    Your thread was helped...

    this..

    Postby oakley » Mon Jan 18, 2016 10:26 am

    I found that the system settings can be changed in the server manager in troubleshooting/parameters. I changed all the external parameters to the correct external ip and opened ports 5000 and 5001 on the firewall. I then sent the welcome emails again and all the devices are now working!
    Thanks for your help as looking thru the welcome email in a text editor showed where the issue was :)
     
  4. ummara

    Joined:
    Jan 21, 2016
    Messages:
    2
    Likes Received:
    0
    Thanx.Problem solved by sending the welcome mail
     
Thread Status:
Not open for further replies.