Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Fanvil X4 light keeps flashing

Discussion in '3CX Phone System - General' started by sjp_crs, Aug 23, 2017.

Thread Status:
Not open for further replies.
  1. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    Fanvil X4 - FW 2.2.0.3770
    3CX Free v15.5.5 (15.5.2849.1)
    Using default templates

    Since the upgrade to 15.5.5 and supported firmware - the Message Waiting light keeps randomly flashing. Sometimes while the phone is idle, sometimes during calls, sometimes on a call but on mute Sometimes it just flashes once, sometimes a few times, sometimes until I press a key or something. No apparent pattern...but it's driving me nuts ;)

    I'm reluctant to push the upgrade to my business clients who have a lot of Fanvil 4s, as I know I'm going to get called a dozen times !

    Any clues ?
     
  2. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs,

    Please note that, the supported firmware for Fanvil X4 is 2.0.4.3496. Fortunately we collected all the supported firmwares for every phone we support here.

    Thank you
     
  3. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    Wellll.....the 3CX system had them all marked as unsupported following the upgrade, and supplied the listed version. On my pre-15.5 SP1 installs, I list 2.0.4.3496 for sure. The firmware file were dated the same day as the 15.5 SP1 update - so I'm pretty sure it came in with that.

    [​IMG]

    I manually downgraded my test phone, deleted any firmware files referencing 2.2.0.3770, and rebooted my test server. Now I get the unsupported firmware message, and it still lists 2.2.0.3770 as being the up-to-date version, so it's in the database somewhere....which means it must have come in through the 3CX side, not just a random upgrade from me ;)
     
  4. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    BTW - it's still doing the weird flashy thing running 2.0.4.3496....
     
  5. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs,

    Please check this. Can you resolve from your network to the downloads directory of 3cx? downloads.3cx.com
    Note that if you can't resolve to the directory for any reason, then your PBX cannot see which one is the appropriate firmware to use and because you installed the firmware manually and then deleted it, your PBX will go look for the last known firmware at the local directory.When it won't find it will list it in your available updates.
     
  6. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    151.80.125.73
    Opening it in a webbrowser gives me a blank page with 'i am here eu' as the title,
     
  7. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs,

    That's because there is nothing to be displayed, it is the directory that you retrieve the firmware from. Opening it with a browser is a good way to check if you can reach a destination but the best way is to execute a nslookup from your terminal, try that too just to make sure.

    Please go to your firmware directory on your local machine C:\ProgramData\3CX\Instance1\Data\Http\Interface\provisioning\xxxxxxxMACaddress\firmware_new/fanvil and check if the firmware is in it.

    Thank you
     
  8. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    I ping, nslookup'd and browsed the address - it resolves just fine.

    The x42.0.4.3496.z is the highest X4 firmware in the folder
     
  9. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs,

    Your problem needs further analysis with more information. I would advise you to open a ticket in our ticketing system for firmware troubleshooting.

    Thank you
     
  10. sjp_crs

    Joined:
    Sep 19, 2016
    Messages:
    34
    Likes Received:
    0
    I'll try and get a ticket out there later today or Monday. I will say it seems less 'flashy' on 2.0.4.3496 than on 2.2.0.3770...but it's still randomly flashing when idle, in calls when talking, in calls when on mute and so on.
     
  11. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs ,

    I've tested a Fanvil X4 with different scenarios and non of these problems occurred. You could take a capture from inside of the phone's interface in order to see what it's triggering this behavior and by whom is triggered.

    Thank you
     
  12. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @sjp_crs,

    Please do check that you don't have any pending voicemails. If you do have, then that's why it's flashing all the time. Make sure that you have deleted all your voicemail messages and then check if the problems occurs.

    Thank you
     
Thread Status:
Not open for further replies.