Fax

Discussion in '3CX Phone System - General' started by Chrisbombak, Jun 14, 2016.

Thread Status:
Not open for further replies.
  1. Chrisbombak

    Joined:
    Jun 14, 2016
    Messages:
    1
    Likes Received:
    0
    Hi All

    I have recently tried to setup a Cisco ATA SPA112 to act as a interface on our fax machine.

    Fax Machine keeps trying to redial all the time.

    Verbose logs below

    14-Jun-2016 15:02:18.108 Leg L:674.1[Fax] is terminated: Cause: BYE from xxx:5061
    14-Jun-2016 15:01:51.921 [CM503007]: Call(C:674): Fax:880 has joined, contact <sip:880@xxx:5061>
    14-Jun-2016 15:01:51.920 L:674.2[Line:10002>>xxxx] has joined to L:674.1[Fax]
    14-Jun-2016 15:01:51.521 [CM503025]: Call(C:674): Calling T:Line:10002>>Dev:sip:xxx@txxx:5060 for L:674.1[Fax]
    14-Jun-2016 15:01:51.472 [CM503027]: Call(C:674): From: Fax:880 ("3CX" <sip:880@xxx:5060>) to T:Line:10001>>xxx@Dev:sip:xxx@txxx:5060
    14-Jun-2016 15:01:51.472 [CM503004]: Call(C:674): Route 2: from L:674.1[Fax] to T:Line:10001>>xxx@Dev:sip:xxx@txxx:5060
    14-Jun-2016 15:01:51.472 [CM503027]: Call(C:674): From: Fax:880 ("3CX" <sip:880@xxx:5060>) to T:Line:10002>>xxx@[Dev:sip:xxx@txxx:5060
    14-Jun-2016 15:01:51.472 [CM503004]: Call(C:674): Route 1: from L:674.1[Fax] to T:Line:10002>>xxx@[Dev:sip:xxx@txxx:5060]
    14-Jun-2016 15:01:51.472 Call(C:674): Call from Fax:880 to xxxx matches outbound rule 'Outbound Loop'
    14-Jun-2016 15:01:51.471 [CM503001]: Call(C:674): Incoming call from Fax:880 to Dev:sip:xxx@txxx:5060
    14-Jun-2016 15:01:51.471 NAT/ALG check:L:674.1[Fax] REQUEST 'INVITE' - basic check passed. No information for extended checks
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    It appears that you are trying to use a 3CX generated fax extension, but I am uncertain what you are trying to do. It looks like you are trying to send and it tried to go out one trunk and could not so went out the second. I am uncertain where it was dialing to, but the issue is most likely that the line was not suitable for a fax to be successful.

    The 3CX generated fax extension are receive only. 3CX does not support fax sending.

    Your best bet is to create and use a standard extension.

    Faxing is risky at best using the internet. While not a perfect solution when using FoIP, it is better if you are able to use t.38 which is the protocol designed to try and overcome some of the issues associated to internet faxing. This then requires the SIP trunk you are using to also be t.38 capable. If not, then the adapter will attempt to use g711 in a pass-through mode, which is not nearly as reliable, but if you have a great provider, a great carrier and send short faxes, you may get lucky.

    Some detail of what you are trying to accomplish along with a verbose trace may provide better insight.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    When the fax machine is dialling, do you hear it connect and attempt to establish a connection (fax tones)? I have a fax machine set-up on a fax extension, if I attempt to go out over my VoIP trunk, which does not accept t.38, a connection with the far end fax machine is attempted, but ends up failing, no re-connection at attempted.

    If I route out over a PSTN trunk using a SPA-3102, the call succeeds. I have not used a 112, but being a newer model, I assume it has t.38 capabilities, which would have to be enabled. Since you are hearing a redial, with the call attempting a second trunk group, you may need to limit the fax extension to a trunk group with only the 112 as a route, to begin with.

    If you force the calls out over the 112, and it still fails (after you hear the far end machine answer), the you have to confirm the t.38 is in fact enabled on the 112. There may also be a setting on your fax machine, to lower the speed, or change error correction, that needs to be changed.
     
Thread Status:
Not open for further replies.