Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Firewall configuration

Discussion in '3CX Phone System - General' started by mfretwell, Jul 9, 2008.

Thread Status:
Not open for further replies.
  1. mfretwell

    Joined:
    May 26, 2008
    Messages:
    25
    Likes Received:
    0
    PBX:3CX Ver 6
    HANDSET: Aastra 55i, FIRMWARE: 2.2.1.25
    FIREWALL: SonicWALL Pro 2040
    VOIP: Vonage

    Inbound calls are not being routed to extension. Here's a copy of the call log.

    Anyone have a similar issue? Could this be a firewall issue?
     
  2. justin

    Joined:
    Feb 20, 2008
    Messages:
    79
    Likes Received:
    0
    Re: Not routing incoming calls YIKES

    I'll ask the obvious question....have you got it set to route incoming calls from that line to either an extension, ring group or digital receptionist? If you try calling that number what do you get? Silence? Busy signal?
     
  3. mfretwell

    Joined:
    May 26, 2008
    Messages:
    25
    Likes Received:
    0
    Re: Not routing incoming calls YIKES

    The obvious can often be obtuse.

    The system is set to route incoming calls, both during and outside of office hours, to Extension 100. I have simplified the routing as much as possible to try to isolate the problem.

    The server log shown below indicates that the call is being routed to DN: 100. However, this extension never rings and Extension 100 on the Line Status screen never turns yellow to indicate a call. The extension is registered and maintains a registered status without a problem.

    There is silence on the call until the system times-out.
     
  4. Henk

    Henk Member

    Joined:
    Nov 13, 2007
    Messages:
    250
    Likes Received:
    0
    Re: Not routing incoming calls YIKES

    Make sure your handset has the correct codecs.

    if it is registered than it the settings for connection is ok. If it rings and you do not hear it ring and for that reasons it times out might be the:

    - Audio settings, make sure the ring is on is there a display on the phone, does it show calling or something like that/
    - codecs
    - dtmf payload
    - codecs payload

    Etc so much so much that can be wrong, but small steps.

    What are your settings on the extension?

    H.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mfretwell

    Joined:
    May 26, 2008
    Messages:
    25
    Likes Received:
    0
    Re: Not routing incoming calls YIKES

    Have solved the forward to extension problem by enabling the Rport (RFC 3581) on the Astra phone.

    Still have only one-way audio. External caller can hear audio from internal but internal extension cannot hear audio from external.

    Using WireShark is see the following errror:
    25419 3021.789500 192.168.0.117 192.168.0.105 ICMP Destination unreachable (Port unreachable)

    192.168.0.117 is the IP of extension 100
    192.168.0.105 is the 3CX server

    Any suggestions?
     
  6. Anonymous

    Anonymous Guest

    Re: Not routing incoming calls YIKES

    Hey there,

    Do you have any firewall/router on the way?

    Thanks,
     
  7. mfretwell

    Joined:
    May 26, 2008
    Messages:
    25
    Likes Received:
    0
    Re: Not routing incoming calls YIKES

    Hi Keith,
    There is a SonicWall Pro 2040 between us and the outside world.
    m
     
  8. Anonymous

    Anonymous Guest

    Re: Not routing incoming calls YIKES

    Can you temporarily setup the PBX as a DMZ to eliminate any possible blocked ports?

    Thanks,
     
Thread Status:
Not open for further replies.