Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

First Post - Easy now :)

Discussion in '3CX Phone System - General' started by jackpod, Aug 15, 2010.

Thread Status:
Not open for further replies.
  1. jackpod

    Joined:
    Aug 13, 2010
    Messages:
    3
    Likes Received:
    0
    First post... I sucessfully have 3cx talking to my cisco 2651 w/2 FXO and 2 FXS (only have 1 pots line coming into the house and the cisco is also doing my DSL authentication and network default gateway) but I have both fxs port connected (1 to physical phones, 1 connected to my way2call connected to Homeseer) I have 4 instances of Xlite on different computers. Calling works in all directions, softphone to outside, outside to softphone, fxs to outside, softphone to softphone. I have the calls currently forwarded to one of the softphones

    my issue. When I setup 3cx, it asked for extensions, fine I did that but I want the incoming call from the pstn gateway to go to the attendant, so I created an additional extension but the attendant box number is not an option in the forwarding... so my question is how do I get an incoming call from the pstn gateway to go to the attendant?

    Below is my 2651 config, I searched and there doesn't seem to be a lot of info on unsupported gateways for 3cx. A couple gottcha's first you have to set the pstn to not register and set your outbound rules to strip the 9. Hope the following config can help someone

    C2651#sh run
    Building configuration...

    Current configuration : 4358 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname C2651
    !
    boot-start-marker
    boot-end-marker
    !
    no logging console
    enable secret 5 $1$frux$hI7F0TDJLVfgdNBlFqexk1
    enable password **********
    !
    no aaa new-model
    clock timezone GMT-7 7
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    ip domain name *******.***
    ip name-server ***.***.***.***
    ip name-server ***.***.***.***
    vpdn enable
    !
    voice service pots
    !
    voice service voip
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    redirect ip2ip
    sip
    !
    voice class codec 11
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8 bytes 40
    codec preference 4 g723r63 bytes 96
    codec preference 5 g726r16 bytes 80
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8 bytes 40
    codec preference 4 g723r63 bytes 96
    codec preference 5 g726r16 bytes 80
    !
    interface ATM0/0
    no ip address
    no ip mroute-cache
    atm restart timer 300
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/32
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface FastEthernet0/0
    ip address ***.***.***.1 255.255.255.0
    ip nat inside
    ip tcp adjust-mss 1452
    speed auto
    full-duplex
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Dialer1
    mtu 1492
    ip address ***.***.***.118 255.255.255.248
    no ip redirects
    no ip proxy-arp
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname *****@******.***
    ppp chap password 0 **********
    ppp pap sent-username *******@******.*** password 0 ***********
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
    !
    ip http server
    no ip http secure-server
    ip nat pool mpool ***.***.***.*** ***.***.***.*** netmask 255.255.255.248
    ip nat inside source list 1 pool mpool overload
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static udp ******************* extendable
    ip nat inside source static udp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static udp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    ip nat inside source static tcp ******************* extendable
    !
    access-list 1 permit ***.***.***.0 0.0.0.255
    snmp-server community public RO
    snmp-server community ********** RO
    snmp-server community host RO
    snmp-server community private RW
    snmp-server enable traps tty
    !
    control-plane
    !
    voice-port 1/0/0
    disconnect-ack
    input gain 4
    output attenuation 4
    no comfort-noise
    description to House Phones
    threshold noise -90
    station-id number 7851
    caller-id enable
    !
    voice-port 1/0/1
    description to HS
    station-id number 7852
    caller-id enable
    !
    voice-port 1/1/0
    output attenuation 0
    no comfort-noise
    connection plar opx 10003
    description 3CX
    station-id name pots incoming
    station-id number ***********
    !
    voice-port 1/1/1
    !
    dial-peer voice 10003 voip
    description 10003
    preference 1
    destination-pattern .T
    voice-class codec 1
    session protocol sipv2
    session target ipv4:***.***.***.17
    dtmf-relay rtp-nte
    no vad
    !
    dial-peer voice 10000 pots
    preference 1
    destination-pattern .T
    port 1/1/0
    !
    dial-peer voice 7851 pots
    destination-pattern 7851
    port 1/0/0
    !
    dial-peer voice 7852 pots
    destination-pattern 7852
    port 1/0/1
    !
    sip-ua
    authentication username 10003 password 0257540B5B55
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers expires 300000
    sip-server ipv4:***.***.***.17:5060
    !
    line con 0
    line aux 0
    line vty 0 4
    password **********
    login
    !
    !
    end

    C2651#
     
Thread Status:
Not open for further replies.