First time set up

Discussion in '3CX Phone System - General' started by gr2010, Dec 11, 2007.

  1. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    Hi,

    I have just down loaded latest free version. After installing the 3CX Phone system in my desktop pc, I am getting the following error when I double click the icon >> Management console, It gives following error message:-


    http://localhost:5481/

    This file does not have a program associated with it for performing action.
    create an association in the folder options panel

    I am not able to open the program to check and configure.

    Pl. suggest me how to fix this. .. thank you!
     
  2. bhavank

    bhavank New Member

    Joined:
    Apr 24, 2007
    Messages:
    109
    Likes Received:
    0
    It seems some issue with the installation, kindly please uninstall and reinstall the software. and then try opening the management console again. if you are unable to login with http://localhost:5481/ try login with ip address of your computer replacing localhost in hyperlink..
     
  3. landfiets

    landfiets New Member

    Joined:
    Jul 17, 2007
    Messages:
    242
    Likes Received:
    0
    same prob

    Hi I had the same problem when I installed it on Windows server 2003 with virusscanner.
    Try uninstall virusscan and do it again.
    When it works then it was your virusscan. When you donnot trust to uninstall the virusscanner give windows server more or different permissions or try different windows or try different virusscanning software.

    Second possibillity. forward the right port in your firewall on the router and on the computer itself (when you use firewall on your computer also)
     
  4. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Third possibillity.
    Make sure Windows DEP (Data Executio Prevention) in turned OFF on win server 2k3.
     
  5. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    Hi,

    I tried to uninstall, install and disable firewall and anti virus. Still I am unable to open the program and it is giving the same error message.

    "if you are unable to login with http://localhost:5481/ try login with ip address of your computer replacing localhost in hyperlink.."

    How do I do this?
     
  6. landfiets

    landfiets New Member

    Joined:
    Jul 17, 2007
    Messages:
    242
    Likes Received:
    0
    more info

    Give us more info. What Windows version. Do you use webinterface on same computer as 3CX? Etc.
     
  7. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I am using Wndows XP Professional SP2
     
  8. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Did you disable FW and AV before or after installing 3cx again?
    This must be off before...

    Did you check win DEP? You find this under Properties for My computer -> Advanced -Z Preformance settings -> Data execution preventin.
    Change setting to "Turn on for Essential Win Programs and Services only".

    You have to figure out the IP the computer 3CX is installed on, and enter this in your web browser. eg IP is 198.168.2.1, you set browser to http://198.168.2.1:5481.
     
  9. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    Do you use webinterface on same computer as 3CX? Etc.

    Yes ...
     
  10. RobLloyd

    RobLloyd Member

    Joined:
    Oct 13, 2006
    Messages:
    488
    Likes Received:
    0
    The web interface can be used anywhere you have access to that IP.
    What's the IP of your XP box? Lets say it's 192.168.1.9.
    Then anywhere on your network go to http://192.168.1.9:5481 and that should bring you to your 3CX login page.
    You need the http:// on there, 192.168.1.9 won't do it since you're going to a different port.

    Also check your firewall on XP. Try turning it off 1st and see if that helps you gain access. If it does, then you need to turn it back on (if you wish) and change it to allow all the ports you need for 3CX to run.
     
  11. landfiets

    landfiets New Member

    Joined:
    Jul 17, 2007
    Messages:
    242
    Likes Received:
    0
    when you try to access the webinterface on the same computer as the 3CX it should be able without IP adress but localhost:xxxx like you did.
    When it is not working, please take a look in the USERS of your XP version
    Did you install it in XP with the Administrator rights?
    That sometimes is a very big problem in XP. Install or access it from the Administrator account and take a look if that helps you out.
     
  12. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    "localhost" is the standard loopback address in DNS (or rather the local hosts file) which refers to the local machine.

    The corresponding IP address for "localhost" is always 127.0.0.1

    If you are having trouble with the URL including "localhost", firstly try and substitute 127.0.0.1 for it and see whether that works. If it does work, the highest probability is that you are either running some firewall software which has modified your local hosts file, or you have had a virus in the past which has also modified it.

    To check your local hosts file, go to %systemroot%\system32\drivers\etc and open the hosts file in notepad. It should have one entry, mapping 127.0.0.1 to localhost.

    (obviously, if it has more then don't go willy-nilly deleting, just post it here and ask!!).

    Cheers,
    Mike.
     
  13. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    It works per Mr. Michael Knowles suggestion. Thank you so Mr. Michale and all others for their suggestion and contribution. I am able to type url: http://127.0.0.1:5481/

    I can see the Main page. However if I want to open the management console menu from program files it is not opening like any other program.

    Do I have to type URL every time to config the program or is there any thing I should do to change settings in the installed files which is at start >> all programs >> 3cx phone system
     
  14. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Nice to hear it worked out.

    To make it more easy to open it you could either copy the shortcut from start >> all programs >> 3cx phone system to your desktop, or draw the url from website down to your desktop.
    Then its always availeble. :wink:
     
  15. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    I tried both and it gives this message:-

    http://127.0.0.1:5481/ (error message header)

    the file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.

    where when i type this url in the browser, it open the 3CX Main page.
     
  16. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    This is for use in your webbrowser, like IE, Firefox, opera and more.
    There is no other program assosiated to 3CX.
     
  17. gr2010

    Joined:
    Dec 11, 2007
    Messages:
    27
    Likes Received:
    0
    thank you for the clarification. How do you link this url to work as per below suggestion:-

    "
    To make it more easy to open it you could either copy the shortcut from start >> all programs >> 3cx phone system to your desktop, or draw the url from website down to your desktop.
    Then its always availeble. "
     
  18. AldoLinares

    AldoLinares New Member

    Joined:
    Nov 12, 2007
    Messages:
    135
    Likes Received:
    0
    You could just save the link to favorites on your explorer.

    You are going to have to enter to some links like that, to your phones, gateways, router etc.. So it's easy if you save it to your favorites.
     
  19. Mori

    Mori New Member

    Joined:
    Mar 23, 2007
    Messages:
    223
    Likes Received:
    0
    Since you say this worked, just go in there, rightclick on the icon (and hold it) then pull it out on desktop.
    Release button, and select 'copy here'.

    Or, just do what 'AldoLinares' says. :)
     
  20. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    The best thing you can do now is correct what localhost refers to now. This would fix your computer rather than fixing 3CX and potentially fixing any other software you install.

    In order to do this, go to START -> Run and type the following:

    notepad.exe %systemroot%\system32\drivers\etc\hosts

    This will open your local hosts file in notepad.

    Check it to see whether there is an entry for localhost - if there is, make a note of what the line says and then delete that line. Then ensure you have one line in there which says:

    127.0.0.1 localhost

    Then save and exit notepad and you should be sorted.

    Cheers,
    Mike.
     

Share This Page