'forbidden' when trying to ring out.

Discussion in 'Windows' started by matt-pfuk, Feb 23, 2011.

Thread Status:
Not open for further replies.
  1. matt-pfuk

    Joined:
    Feb 23, 2011
    Messages:
    6
    Likes Received:
    0
    Hello,

    I had this all working locally, then when I tried to use the system remotely from another site, I get "Forbidden" show up on the softphone. The 3CX Management Console, says:

    Code:
    12:06:02.928  Requests rate from IP xx.xx.xx.xx is too high! Blacklisted for 334 seconds
    I also get "Authentication failed" show up on the softphone. But the The 3CX Management Console, says:

    Code:
    12:06:51.210  [CM504002]: Ext.12: a contact is unregistered. Contact(s): []
    When Ext. 12 is registered and I have double checked all the passwords and they are all the same!

    But the softphone receives calls fine.

    Any ideas/suggestions would be a great help.

    Thanks,
    Matt
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    228
    I'm assuming that the IP you x'd out is a public IP and that you have STUN enabled on the softphone when used remotely.
     
  3. matt-pfuk

    Joined:
    Feb 23, 2011
    Messages:
    6
    Likes Received:
    0
    You assume correct.

    Matt
     
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    And you have firewalls open?

    If you are using the softphone I would suggest using the tunnel and make sure port 5090 is open on your firewall. You will have less problems that way as it all goes through that port.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. matt-pfuk

    Joined:
    Feb 23, 2011
    Messages:
    6
    Likes Received:
    0
    Okay thanks for your help

    Yeah i had all ports open no firewall active.

    Matt
     
  6. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,406
    Likes Received:
    81
    What abc123 is saying is that you should use the 3CXPhone with the tunnel feature.
    Simply configure the 3CXPhone to connect to the PBX with the tunnel feature by using the appropriate settings available to you and this issue shouldn't happen anymore.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. matt-pfuk

    Joined:
    Feb 23, 2011
    Messages:
    6
    Likes Received:
    0

    Okay thanks for all your help guys!!!

    Matt
     
Thread Status:
Not open for further replies.