Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Forward to External Number "call transfer failed"

Discussion in '3CX Phone System - General' started by philip_b, Sep 7, 2010.

Thread Status:
Not open for further replies.
  1. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    Greetings-

    I have a forwarding rule that I can't seem to make work. What I'd like to do is ring all extensions and then forward the call to an answering service.

    I have setup the auto attendant to connect to a ring group when a caller hits "0" - this forwards the call to a ring group and rings all extensions for 30 seconds. If not answered it should forward the call to an 800-service operator that is external.

    I have forwards to external numbers enabled in Settings - General Settings - Global Options - Allow forwarding

    And I also have enable external forwards for a particular extension, but I still get a "Call Transfer Failed - No Answer" message.

    I have double checked my outbound rules and the call should not be blocked there...

    Also looked at the other forum entries with no luck. I have nosed around the admin GUI and can't seem to find the setting that is blocking me. Also looked here without success: http://www.3cx.com/user-manual/forwarding/ (updated link)

    Also, I have 4 lines available and have tested the ability to generate simultaneous outbound calls.

    IF anyone has any thoughts (probably something stupid that I have missed) I would appreciate it.

    Thanks.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    Post the 3CX log from the point of the incoming call, to the ring group, and then forwarded to the external number.
     
  3. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    Thanks for taking a look at this.

    THe call comes in and I hit Option 0 in teh auto attendant which should route the call to a ring group which rings 3 extensions for 30 seconds... if not answered it should route to an external number.



    10:00:27.130 [CM503008]: Call(1359): Call is terminated
    10:00:20.833 [CM503003]: Call(1359): Call to sip:113@192.168.180.5 has failed; Cause: 487 Request Cancelled; from IP:192.168.180.28:5060
    10:00:20.818 [CM503003]: Call(1359): Call to sip:112@192.168.180.5 has failed; Cause: 487 Request Cancelled; from IP:192.168.180.29:5060
    10:00:20.755 [CM503003]: Call(1359): Call to sip:111@192.168.180.5 has failed; Cause: 487 Request Cancelled; from IP:192.168.180.37:5060
    10:00:20.755 [CM503016]: Call(1359): Attempt to reach <sip:802@127.0.0.1:5060> failed. Reason: No Answer
    09:59:58.380 Active calls counted toward license limit: [1359]
    09:59:50.958 [CM505001]: Ext.113: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_600-UA/3.0.3.0401] PBX contact: [sip:113@192.168.180.5:5060]
    09:59:50.958 [CM503002]: Call(1359): Alerting sip:113@192.168.180.28:5060
    09:59:50.943 [CM505001]: Ext.111: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_600-UA/3.0.3.0401] PBX contact: [sip:111@192.168.180.5:5060]
    09:59:50.943 [CM503002]: Call(1359): Alerting sip:111@192.168.180.37:5060
    09:59:50.927 [CM505001]: Ext.112: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_600-UA/3.0.3.0401] PBX contact: [sip:112@192.168.180.5:5060]
    09:59:50.927 [CM503002]: Call(1359): Alerting sip:112@192.168.180.29:5060
    09:59:50.662 [CM503025]: Call(1359): Calling RingAll802:111Ext.111112Ext.112113Ext.113@[Dev:sip:113@192.168.180.28:5060]
    09:59:50.662 [CM503025]: Call(1359): Calling RingAll802:111Ext.111112Ext.112113Ext.113@[Dev:sip:112@192.168.180.29:5060]
    09:59:50.646 [CM503025]: Call(1359): Calling RingAll802:111Ext.111112Ext.112113Ext.113@[Dev:sip:111@192.168.180.37:5060]
    09:59:50.583 [CM503004]: Call(1359): Route 1: RingAll802:111Ext.111112Ext.112113Ext.113@[Dev:sip:111@192.168.180.37:5060,Dev:sip:112@192.168.180.29:5060,Dev:sip:113@192.168.180.28:5060]
    09:59:50.583 [CM503010]: Making route(s) to <sip:802@127.0.0.1:5060>
    09:59:50.583 [CM505003]: Provider:[Nexvortex - US] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Zultys MX250 v5.2.17 build 2] PBX contact: [sip:clientname@173.164.00.122:5060]
    09:59:45.708 [MS211000] C:1359.1: 4.55.5.130:12316 is delivering DTMF using RTP payload (RFC2833). In-Band DTMF tone detection is disabled for this call segment.
    09:59:41.646 [CM503007]: Call(1359): Device joined: sip:800@127.0.0.1:40600;rinstance=12686387df9fddc2
    09:59:41.646 [CM503007]: Call(1359): Device joined: sip:clearpath@66.23.129.253:5060
    09:59:41.630 [CM505001]: Ext.800: Device info: Device Identified: [Man: 3CX Ltd.;Mod: 3CX IVR;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX IVR] PBX contact: [sip:800@127.0.0.1:5060]
    09:59:41.630 [CM503002]: Call(1359): Alerting sip:800@127.0.0.1:40600;rinstance=12686387df9fddc2
    09:59:41.427 [CM503025]: Call(1359): Calling Ext:Ext.800@[Dev:sip:800@127.0.0.1:40600;rinstance=12686387df9fddc2]
    09:59:41.412 [CM503004]: Call(1359): Route 1: Ext:Ext.800@[Dev:sip:800@127.0.0.1:40600;rinstance=12686387df9fddc2]
    09:59:41.412 [CM503010]: Making route(s) to <sip:800@192.168.180.5:5060>
    09:59:41.412 [CM505003]: Provider:[Nexvortex - US] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Zultys MX250 v5.2.17 build 2] PBX contact: [sip:clearpath@173.164.38.122:5060]
    09:59:41.396 [CM503001]: Call(1359): Incoming call from +1303819XXXX@(Ln.10000@Nexvortex - US) to <sip:800@192.168.180.5:5060>
    09:59:41.287 [CM503012]: Inbound out-of-office hours rule (unnamed) for 10000 forwards to DN:800
     
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    From my understanding of your description and going by the logs....

    An incoming call rings the attendant and when they press 0 it routes to the group to ring all in the group.

    If no answer after 30 seconds you have the group try to forward a call to an outside number?

    And the forwarding is failing?

    Did you check the box in the Settings > General > Global Options .... Allow forwarding to external numbers in Ring Groups and Queues?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    Yes, I did select the option to allow forwarding but it had no impact.

    Thanks
     
  6. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Did you reset the services when you made the change? I always like to when making a config change like that.

    If so then we can work backwards.

    Firstly can you call the external number from one of the extensions in the ring group directly? This will check the extension can make the call and also the outbound rules are set up.

    If you can call from the extension then it is up to the ring group (is it a group or queue). Make sure the number in the ring group is set up to match your outbound rules (ie do you need to dial a 1 or did you only have certain extensions in your outbound rule?)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    Not sure what you mean by reset services - I made changes and applied them, but didn't restart the server or any services.

    Yes, I can make calls to the external numbers (and for testing substituted my cell and I can call out to the cell without issue).

    Yes, it is a Ring Group. I had actually tried every combination of the leading digits (by default I should dial a "1" to dial externally) and nothing worked.

    I just rebooted the server with no impact. THen I cleared all the other extensions from teh ring group and left only mine - and set that forward externally - this also failed.

    Very perplexing - I appreciate your thoughts and if you have any other ideas (including sacrificing a chicken) I'm willing to try.

    Thanks!
     
  8. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    There are still a few more things to try

    Try setting up a queue instead. Add just 1 extension and see if that works.

    Also just try calling the queue/group from internally (e.g ext 111 to group ext 800)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    I created a queue (with no extensions logged in) and set the no answer to forward to my cell and it worked while calling from inside.

    Same for a new ring group and the old problematic ring group - all worked correctly and forwarded to my cell when called from the inside, but all fail when calling from an outside number.

    I went back to the settings - general - global and hovered the mouse over the help button for "Allow forwarding" and I get a very confusing popup about accepting a call after the callee has answered...

    When a call originates from outside the PBX, what should the outbolund rule be?

    Thanks.
     
  10. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    I think I have it resolved.

    I played around with a very generic outbound rule (in addition to the rule for my VOIP provider) and basically said any calls that have a 9,10,11 digit length send along this route and everything started working.

    Very annoying, but apparently my default rule had a bunch of extension ranges in it and while this is not enforced for internal calls, the extension is enforced for external calls.

    When I created a rule with no extensions everything started working... didn't even have to sacrifice a chicken!
     
  11. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Glad you got it working and saved a chicken or two! Outbound rules would have been next on our list depending on the results of the test I had you run. But you fixed it.

    Just out of interest, did you need the Digital Assistant? It wasn't clear if you were just using it to forward to the group or whether that group was part of a larger menu system?

    You can route an inbound rule directly to a ring group or queue and if you need an intro then use a group.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
    Yes - need the DigitalAssistant as part of a larger menu system.

    One other item did come up that is part of this... when ring group gets a call and rings all members of that group at the same time, only extensions that are not busy get the call.

    If an extension is called directly that is busy, the extension still receives the second call and the user has the option to ignore or park the first call and take the second... this doesn't seem to be the behaviour on RIngGroups and Queues.

    Is it possible to turn that on somewhere?

    Thanks for all your input.
     
  13. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Not that I know of

    I have the same problem. There used to be a checkbox to say use pbx or phone status for busy but it isnt in v9. Maybe when they dropped it they changed how it works.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. philip_b

    Joined:
    Sep 6, 2010
    Messages:
    9
    Likes Received:
    0
Thread Status:
Not open for further replies.