Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Forward to Outside Number Problem from Ring Group

Discussion in '3CX Phone System - General' started by muaddib32, Sep 2, 2011.

Thread Status:
Not open for further replies.
  1. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Trying to forward unanswered calls to an external answering service. This works fine for an extension. But because I want calls to be handled differently during work hours and after-hours I have set up a ring group. But the ring group will not forward calls to an external number. I have checked the box "Allow forwarding to external numbers.." in General, Settings.

    How do I get this to work?
     
  2. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    hello,

    How do you have calls handled generally outside of office hours? do you allow external calls outside of office hours?
    do you have external calls on your trunks disabled outside office hours?

    Thanks,
    Nate
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Does it matter? I am trying to get the system to forward unanswered calls during work hours to an external number using a ring group.
     
  4. nbailey

    nbailey Member

    Joined:
    Jan 31, 2011
    Messages:
    359
    Likes Received:
    0
    It does actually, you didn't specify in or out of office hours, now I know you mean in office hours so now it doesn't matter. Have you checked the logs too see why it is not working?
    did you format the number to work with your outbound rules?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    It works fine when diverting from an extension
     
  6. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    The Server Activity Log says that the call was terminated. No Answer. It is supposed to be forwarding not terminating
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,123
    Likes Received:
    330
    Post the log of a failed call. I assume that there is a spare trunk available for the call.
     
  8. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    -There is only the one line, but it works when forwarded from an extension

    09:51:27.471 [CM503003]: Call(2): Call to sip:100@192.168.64.7 has failed; Cause: 487 Terminated; from IP:192.168.64.14:5060
    09:51:27.369 [CM503020]: Normal call termination. Reason: No answer
    09:51:27.369 [CM503016]: Call(2): Attempt to reach <sip:800@192.168.64.7:5060> failed. Reason: No Answer
    09:51:24.929 [CM505001]: Ext.100: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [DPH 125MS 1.14.27] PBX contact: [sip:100@192.168.64.7:5060]
    09:51:24.928 [CM503002]: Call(2): Alerting sip:100@192.168.64.14:5060
    09:51:24.252 [CM503025]: Call(2): Calling RingAll800:100Ext.100@[Dev:sip:100@192.168.64.14:5060]
    09:51:24.248 [MS210002] C:2.2:Offer provided. Connection(transcoding mode): 192.168.64.7:7002(7003)
    09:51:24.219 [CM503004]: Call(2): Route 1: RingAll800:100Ext.100@[Dev:sip:100@192.168.64.14:5060]
    09:51:24.215 [CM503010]: Making route(s) to <sip:800@192.168.64.7:5060>
    09:51:24.213 [MS210000] C:2.1:Offer received. RTP connection: 203.176.185.10:38350(38351)
    09:51:24.208 Remote SDP is set for legC:2.1
    09:51:24.206 [CM505003]: Provider:[Comvergence] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Sippy] PBX contact: [sip:61390085250@150.101.163.242:5060]
    09:51:24.197 [CM503001]: Call(2): Incoming call from 0418146132@(Ln.10001@Comvergence) to <sip:800@192.168.64.7:5060>
    09:51:23.896 [CM503012]: Inbound outside specific hours incl. holidays rule (unnamed) for 10001 forwards to DN:800
    09:51:23.895 Looking for inbound target: called=61390085250; caller=0418146132
    09:51:23.885 [CM500002]: Info on incoming INVITE:
    INVITE sip:61390085250@192.168.64.7:5060;rinstance=661038a060db3992 SIP/2.0
    Via: SIP/2.0/UDP 203.176.185.10;branch=z9hG4bK5fe6.1bbe0f98b56544654b4383fb1a562191.0
    Via: SIP/2.0/UDP 203.176.185.10:5061;branch=z9hG4bK047320b5b6efc7f4fe330b96f5c7f6f7;rport=5061
    Max-Forwards: 16
    Record-Route: <sip:203.176.185.10;ftag=e81e1dd3a01ad5346039b5962d158356;lr>
    Contact: "Anonymous"<sip:203.176.185.10:5061>
    To: <sip:61390085250@203.176.185.10>
    From: <sip:0418146132@203.176.185.10>;tag=e81e1dd3a01ad5346039b5962d158356
    Call-ID: call-71A2623A-40B8-2E10-0B06-3E0C2@203.176.186.10~1o
    CSeq: 200 INVITE
    Expires: 300
    User-Agent: Sippy
    Content-Length: 0
    cisco-GUID: 879048241-1714970979-1717986918-1697669730
    h323-conf-id: 879048241-1714970979-1717986918-1697669730
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,123
    Likes Received:
    330
    You mean you only have one trunk? Hmmmm

    If you do have more than one trunk...

    What you can try...is create a dummy extension, say, 200. This doesn't require that you have a physical set., forward that extension to your outside number. Call it (200) directly to be sure it works. Next forward the unanswered call in the ring-group to 200. Call the ring-group (800) from an extension (not the one in the group), does it forward to the outside number if not answered? If yes, then try an outside call.
     
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,123
    Likes Received:
    330
    Forgot about this...In Settings/General/Global Options/System Wide Options, there is an option to allow calls to outside numbers from ring-groups. Did you have that checked? If not, try it and you can probably ignore the above post.
     
  11. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Thanks leejor. Yes, I already have that option checked. Makes no difference. But your suggestion of diverting to a dummy extension works perfectly. Thanks.
     
Thread Status:
Not open for further replies.