Fresh Install on Server 2008 R2 having errors

Discussion in '3CX Phone System - General' started by soltech2, Jun 16, 2013.

Thread Status:
Not open for further replies.
  1. soltech2

    Joined:
    Apr 1, 2013
    Messages:
    5
    Likes Received:
    0
    I have done a fresh install of V11 on Server 2008 R2. I did all Windows updates before installing 3CX. The install finishes without problem, but when you try and goto the management console you get a blank white screen on FF after login and the following error shows up in the Application event log:

    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Runtime.InteropServices.SEHException
    Stack:
    at System.Threading.Thread.InternalCrossContextCallback(Context ctx, IntPtr ctxID, Int32 appDomainID, InternalCrossContextDelegate ftnToCall, Object[] args)
    at System.Runtime.Remoting.Channels.CrossContextChannel.SyncProcessMessage(IMessage reqMsg)
    at System.Runtime.Remoting.Channels.ChannelServices.SyncDispatchMessage(IMessage msg)
    at System.Runtime.Remoting.Channels.CrossAppDomainSink.DoDispatch(Byte[] reqStmBuff, SmuggledMethodCallMessage smuggledMcm, SmuggledMethodReturnMessage& smuggledMrm)
    at System.Runtime.Remoting.Channels.CrossAppDomainSink.DoTransitionDispatchCallback(Object[] args)
    at System.Threading.Thread.CompleteCrossContextCallback(InternalCrossContextDelegate ftnToCall, Object[] args)
    at System.Threading.Thread.InternalCrossContextCallback(System.Runtime.Remoting.Contexts.Context, IntPtr, Int32, System.Threading.InternalCrossContextDelegate, System.Object[])
    at System.Runtime.Remoting.Channels.CrossAppDomainSink.DoTransitionDispatch(Byte[], System.Runtime.Remoting.Messaging.SmuggledMethodCallMessage, System.Runtime.Remoting.Messaging.SmuggledMethodReturnMessage ByRef)
    at System.Runtime.Remoting.Channels.CrossAppDomainSink.SyncProcessMessage(System.Runtime.Remoting.Messaging.IMessage)
    at System.Runtime.Remoting.Proxies.RemotingProxy.CallProcessMessage(System.Runtime.Remoting.Messaging.IMessageSink, System.Runtime.Remoting.Messaging.IMessage, System.Runtime.Remoting.Contexts.ArrayWithSize, System.Threading.Thread, System.Runtime.Remoting.Contexts.Context, Boolean)
    at System.Runtime.Remoting.Proxies.RemotingProxy.InternalInvoke(System.Runtime.Remoting.Messaging.IMethodCallMessage, Boolean, Int32)
    at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(System.Runtime.Remoting.Messaging.IMessage)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(System.Runtime.Remoting.Proxies.MessageData ByRef, Int32)
    at Aprelium.FCGIDotNet_4_0.Host.ProcessRequest(Aprelium.FCGIDotNet_4_0.Connection)
    at Aprelium.FCGIDotNet_4_0.Connection.ProcessOneRequest()
    at Aprelium.FCGIDotNet_4_0.Server.OnRequestAccept(System.Object)
    at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object)
    at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
    at System.Threading.ThreadPoolWorkQueue.Dispatch()
    at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    I have uninstalled and reinstalled several times and that does not resolve the issue. I have also removed .Net Framework and reinstalled, still no help. So I'm rather stuck at this point.

    Christopher
     
  2. cobaltit

    cobaltit Well-Known Member

    Joined:
    Mar 22, 2012
    Messages:
    1,165
    Likes Received:
    179
    @Christopher


    I had a similar issue with a fresh install. I ended up repairing .Net 4.0 from the Programs menu, and then restarting all the services (3CX and IIS). It was a while back so I can't remember the exact message but it seems similar.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. soltech2

    Joined:
    Apr 1, 2013
    Messages:
    5
    Likes Received:
    0
    I have repaired the .Net services, uninstalled and reinstalled 3CX and still have the issue.
     
  4. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    316
    Likes Received:
    1
    @crspencer

    Please try to load up the "Windows Management Console" and advise the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. soltech2

    Joined:
    Apr 1, 2013
    Messages:
    5
    Likes Received:
    0
    I can get to and enter the username and password, after I click login I just get a blank white screen, though the system seems to be functioning properly in the background.
     
  6. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    1
    I'd remove the site and appPool from the IIS config after uninstalling.. this and other apps tend to leave entrails in IIS after uninstalling.. messes up the reinstall most of the time.
     
  7. soltech2

    Joined:
    Apr 1, 2013
    Messages:
    5
    Likes Received:
    0
    I'm using Abyss, not IIS.
     
  8. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    316
    Likes Received:
    1
    @crspencer

    For a deeper look at this from 3CX, you will need to open a support ticket.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.