Frustrating- Call failed, forbidden

Discussion in '3CX Phone System - General' started by SKJoy2001, Jun 30, 2014.

Thread Status:
Not open for further replies.
  1. SKJoy2001

    Joined:
    Mar 24, 2014
    Messages:
    5
    Likes Received:
    0
    This has become a seriously frustrating issue for the last 2 days!

    I have set up 3CX Phone System on a PC that is connected to a WiFi with IP of 192.168.1.4 and the WiFi Router forwards all required TCP/UDP traffic (5060, 5061, 5090, etc.) from the real IP 20x.19x.12x.17x to this local IP 192.168.1.4 and that is the network topology so far.

    3CX Phones on Android systems are connecting to the server very nicely, even from remote locations outside of the LAN. The trouble is, when the clients are within the LAN (192.168.1.x), everything works perfectly and the error of "Call failed, forbidden" show up when trying from remote networks that connect to the server through real IP and router's port forwarding!

    I believe this has something to do with CID or caller identification. Everywhere I looked says to add the CID mas to VoIP Provider list! I just don't get it, I am sorry. I am not associated with any VoIP provider, I just want to use the system through the real IP with router port forwarding as it is being used within the LAN!

    CLIENTS === INTERNET === ROUTER <= PORT FORWARD => 3CX Phone System === LAN === CLIENTS

    Here the LAN side clients work perfectly but the INTERNET side clients can receive only, can't make calls due to "Call failed, forbidden" issue.

    If anyone there to help out, please do receive my thanks in advance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. AndreasP_3CX

    AndreasP_3CX New Member
    3CX Support

    Joined:
    Feb 15, 2013
    Messages:
    196
    Likes Received:
    2
    Hi SKJoy2001

    Can you please do the following for me and let me know if it makes a difference?

    1) go to extension settings and make sure that the following are unchecked.
    - " disallow use of extension outside the lan"

    2) go to Settings>>General>> Advanced >> and in the local sip domain enter your EXTERNAL ip Address or your local fqdn

    please let us know how it goes for you
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.