Galaxy S unable to connect tunnel

Discussion in 'Android' started by eeknz, Jun 8, 2012.

Thread Status:
Not open for further replies.
  1. eeknz

    Joined:
    Jun 8, 2012
    Messages:
    3
    Likes Received:
    0
    Galaxy S - Gingerbread 2.3.3
    3CX Phone for android 2.0.3

    App works fine in the office over WiFi, and in remote location with site to site VPN with phone set to in office.
    Softphone on a PC can connect via the tunnel to the same extension on both WiFi, and tethered to the android over 3G.

    Have toggled NAT helper, ICE, and TCP transport with no effect.
    Have tried IP and DNS name as the external server address.
    3CX in the office has DNS name set as external ID.
    Have retyped the password for the tunnel a number of time to verify it's not a typo.

    My conclusion;
    The office will accept tunnel connections as the PC can establish one.
    The cell provider is not blocking 5090 as the PC can make a tunnel using the phone as a link.
    The extension allows out of office access as the PC works in all configurations, and the android works with the site 2 site VPN.
    The extension settings are correct because the android works 'in office' mode.

    I have removed, rebooted and reinstalled. The profiles were retained and show the same behavior.
    The is no update to the OS in this device without rooting it.

    Seems to me like the tunnel just doesn't work.

    What else could I try?
     
  2. eeknz

    Joined:
    Jun 8, 2012
    Messages:
    3
    Likes Received:
    0
    Turns out it was my fault. The router has TCP 5090 forwarded, no UDP. Doesn't seem to matter for the PC softphone, but the Android one needs UDP it would seem.
     
Thread Status:
Not open for further replies.