Getting PAP2-NA to Route with Port

Discussion in '3CX Phone System - General' started by motormal, Jul 5, 2012.

Thread Status:
Not open for further replies.
  1. motormal

    Joined:
    Jul 5, 2012
    Messages:
    6
    Likes Received:
    0
    I have a PAP2-NA that I'm trying to configure for 3CX. It seems to be *almost* working and I'm wondering what simple thing I'm missing. The phone plugged into the ATA can talk to the 3CX server and receives incoming calls. Outgoing calls from this phone fail (busy signal). Outgoing calls from a 3CX soft phone I have running on a computer are OK.

    In the Server Activity Log I see that ATA phone fails with the messages:
    Making route(s) to <sip:555555555@192.168.2.3>
    No known route to target: <sip:555555555@192.168.2.3>
    Attempt to reach <sip:555555555@192.168.2.3> failed. Reason: Not Found

    The soft phone succeeds at this step with:
    Making route(s) to <sip:555555555@192.168.2.3:5060>

    So it seems to me the ATA isn't specify the port (5060) on the sip route request. Anyone know how to configure the ATA or the server to get the port appended?

    Thanks, and cheers!
    malcolm
     
  2. paul.hadley

    paul.hadley New Member

    Joined:
    Aug 24, 2010
    Messages:
    122
    Likes Received:
    0
    Can you dial from the PAP2-NA to another extension on the 3CX system. If you can I think the problem might not be in the PAP2-NA settings but in the 3CX outbound rules.

    Is the route that selects the provider for calls to "555555555" limited to certain extensions or extension groups. May be the softphone extension is included in the dial plan but not the extension number for the PAP2-NA.
     
  3. motormal

    Joined:
    Jul 5, 2012
    Messages:
    6
    Likes Received:
    0
    My ATA Info page looks like this:
    http://tinypic.com/r/1zfr5kz/6

    paul:
    I can't dial to other extensions. Same failure point:
    No known route to target: <sip:102@192.168.2.3>
    I'll poke around in anything that looks suspicious in the settings you mention.
     
  4. motormal

    Joined:
    Jul 5, 2012
    Messages:
    6
    Likes Received:
    0
    My bad, extension 102 was the ATA. When I tried the soft phone extension (100) it went through.
    Seems strange that the soft phone can get out to a number and the ATA phone can't get out to that same number.
     
  5. paul.hadley

    paul.hadley New Member

    Joined:
    Aug 24, 2010
    Messages:
    122
    Likes Received:
    0
    My PAP2 does show the :5060 but I didn't do anything special when I set it up.

    Try adding the :5060 to the end of the IP address you register to in the PAP2 and see if that makes any difference.
     
  6. motormal

    Joined:
    Jul 5, 2012
    Messages:
    6
    Likes Received:
    0
    I deleted and re-added my Outbound Rule to my voip provider. Everything works. For any others reading this post I didn't append the port to the IP in the ATA. Something just seemed to be messed with the Outbound Rule - even though both the soft phone and the ATA extensions where configured to use the same rule.
     
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    You didn't have any extension (range) restrictions in the outbound rule by chance?
     
  8. motormal

    Joined:
    Jul 5, 2012
    Messages:
    6
    Likes Received:
    0
    I didn't, the extensions field was blank.
     
Thread Status:
Not open for further replies.