Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Google Cloud Hosting - |Email

Discussion in '3CX Phone System - General' started by ccomley, Nov 23, 2016.

Thread Status:
Not open for further replies.
  1. ccomley

    Joined:
    Apr 6, 2011
    Messages:
    95
    Likes Received:
    4
    This is a Hint-n-Tip post.

    3CX documentation confirms that Google Cloud compute-engine hosts will NOT be able to send outbound mail on any of the traditional SMTP ports, esp not port 25 which is what 3CX expects to use.

    I've set up my firewall at the office to accept email on port 26. (well, technically it accepts traffic on port 26 and passes it to port 25 of the mail server, which never knows anything odd happened).

    I was playing with IPTables on the Google hosted Debian to re-route outbound port 25 traffic to port 26 but couldn't get it to behave. Then I found a hidden setting in the 3CX PARAMETERS table which tells 3CX to use port 26 to start with. The parameter is

    MLSRVPORT
     
  2. mahe23

    Joined:
    Apr 28, 2009
    Messages:
    23
    Likes Received:
    0
    Here is an additional hint:

    1. You can use a smtp provider: www.smtp2go.com
    2. Create a free account. They use the port 2525 which is open at Google Cloud
    3. Go to 3CX Mail-Settings and enter : mail.smtp2go.com:2525 as the Mailserver
    4. Add your ID and PW for SMTP2go.com. It works with/without SSL/TLS
    5. Now you can receive your provisioning files by mail.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mo@closetrak.com

    Joined:
    Feb 9, 2016
    Messages:
    2
    Likes Received:
    0
    I'm going to try it now
     
  4. salomaowk

    Joined:
    Jan 23, 2017
    Messages:
    3
    Likes Received:
    0
    It works!

    Thank you all for this information!
     
Thread Status:
Not open for further replies.