Google Push Android not working

Discussion in '3CX Phone System - General' started by minnesota, Feb 15, 2017.

Thread Status:
Not open for further replies.
  1. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1
    Hello, we're on the latest SP4 version of 15 Linux 3CX.

    https://www.3cx.com/docs/configuring-google-push/

    I have followed the guide at the link here to setup Google Push for our Android devices. Unfortunately, I cannot get it to work properly. When the phone goes into standby, the incoming calls to the user extensions does not ring the Android devices. The 3CX app only rings the phone if it is open and screen on.

    I have checked the firewall and all ports are open correctly. I've also copied API and Project ID into 3CX server as in the guide.

    One step I might be confused on is Step 8 in the guide where it says choose "Google Cloud Messaging" but later in the run-on sentence, it says to choose "Other UI". I have select Google Cloud Messaging instead of Other API. Is this correct or which one should I select? The guide says to choose both options which is not possible.

    After setting the API and Project IP in 3CX properly, we have uninstalled the 3CX app on the phones, resent the welcome emails. Then reinstalled 3CX and provisioned them using the latest link in the welcome email.

    Still they do not ring when the phone is in standby. Our iPhones ring fine all the time and never have missed calls in standby.

    Any help would be appreciated. Thank you
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,479
    Likes Received:
    466
    Hello @minnesota

    I have set up a google push account and i chose Google cloud messaging at step 8. It worked properly. Make sure though that you have set your public IP like described in steps 9 and 10. If not then create a new project and try again.
     
  3. Ramkumar

    Joined:
    Apr 28, 2017
    Messages:
    3
    Likes Received:
    0
    Hi Team

    We have the same issue but the platform is windows server. i have doubled check the API Key and ID. all correct but it is not working.. even if i have fix restricted keys to None also having the issue. But I phone is working fine.. How can we settled. we are using only soft phone on the user smartphone.
     
Thread Status:
Not open for further replies.