Grandstream 2020 Registration Issue

Discussion in '3CX Phone System - General' started by lonestar.computer, Jan 27, 2008.

  1. lonestar.computer

    Joined:
    Jan 27, 2008
    Messages:
    16
    Likes Received:
    0
    I just setup a new pair of Grandstream 2020's and a newly downloaded free copy of 3CX(ver 5.03790.0). I configured three new lines - two for the 2020's and 1 3CX soft phone. The problem is that none of these will register. I think they are all setup correctly SIP IP and passwords - everything else is default. Any suggestions?
     
  2. blackflash76

    Joined:
    Dec 18, 2007
    Messages:
    9
    Likes Received:
    0
    Maybe you should turn off Firewall on the computer where 3CX is installed.
     
  3. matthijsolislagers

    matthijsolislagers New Member

    Joined:
    Jan 22, 2008
    Messages:
    140
    Likes Received:
    0
    Can you post your server log please.
     
  4. lonestar.computer

    Joined:
    Jan 27, 2008
    Messages:
    16
    Likes Received:
    0
    Thanks for the posts;

    I have turned off the firewall but authentication is failing. See logs below:

    14:37:31.200 AuthMgr::eek:nAuthFailure [CM102001]: Authentication failed for SipReq: REGISTER 192.168.1.14 tid=687ffb94a37aff6a cseq=REGISTER contact=rodney@192.168.1.8:5060 / 10002 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    14:37:30.900 printDetailedInfo [CM502001]: Source info: From: "Rodney Whiddon"[sip:rodney@192.168.1.14];tag=303c209f33b4bd6a; To: [sip:rodney@192.168.1.14]
    14:37:30.900 evt::CheckAuth::not_handled [CM302002]: Authentication failed due to unidentified source of: SipReq: REGISTER 192.168.1.14 tid=687ffb94a37aff6a cseq=REGISTER contact=rodney@192.168.1.8:5060 / 10002 from(wire)

    I did try adding a softphone and I used the "use 3cX authentication" and it conected OK and the server showed the extention in use. When I tell the soft phone to connect using the "SIP Server /voip provider" it will not connect.


    I have tried changing the password to null and to other values - no luck. I am assuming the grandstream 2020 does work with this pbx???
    I tried stopping the 3CX service and restarting
     
  5. blackflash76

    Joined:
    Dec 18, 2007
    Messages:
    9
    Likes Received:
    0
    I've simulated your error. When you config your GXP2020 you have to insert in the field SIP-User ID the nummber of the extention and not the name.
     
  6. lonestar.computer

    Joined:
    Jan 27, 2008
    Messages:
    16
    Likes Received:
    0
    I got it to work. Changed the SIP ID, auth ID and auth password to match the station #.
     

Share This Page